This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by matyasH 5 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 14, 2019 at 1:15 pm

matyasH

When a customer chooses a language version at first time, language version should stay with him during hole visit. But it does not work. Please lets try to buy something as s German. On every single page, You have over and over choose language again because language always goes to default language. Do You understand me?

Link to a page where the issue can be seen: hidden link

So how can I do it?

May 14, 2019 at 4:13 pm #3809067

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I just tested this on your site and I can see the issue happening.

Can you please try this:

First, create a full backup of your current website.

Then:

- disable all plugins except WPML and its add-ons (leave WooCommerce active, too)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know what you are able to find.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 15, 2019 at 6:36 am #3812607

matyasH

My issue is resolved now. Thank you!