Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 3 voices.

Last updated by georgiaT 4 years ago.

Assigned support staff: Bruno.

Author Posts
November 16, 2017 at 2:40 pm #1432823

georgiaT

Hello,

After updating to WPML Multilingual CMS and WP 4.9, I got the below error :
"Language code must have format 2-3 letters and. optionally, hyphen, underscore followed by 2 more letters"

I have checked the https://wpml.org/errata/hreflang-does-not-use-the-language-tag/ page and tried the workaround, however with no success.

After the edit i got the below error :
"b(...).not(...).filter(...).mediaelementplayer is not a function"

Visual Composer doesn't load, javascript doesn't work even on simple things like changing from visual to text editor on default wordpress editor.

How can I fix this?

November 18, 2017 at 1:41 pm #1434669

Bruno

Hi,

Please apologize for the delay in answering. This is not usual in this forum.

After the edit i got the below error :
"b(...).not(...).filter(...).mediaelementplayer is not a function"

Please, could you post a bit more of the error message being displayed?

Also, can you access the WPML> Support page? If so, please, I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

November 20, 2017 at 2:50 am #1435249

Jörg

This is a bug in WP 4.9 with formal languages variants, see:
https://core.trac.wordpress.org/ticket/42574

November 20, 2017 at 9:31 am #1435441

georgiaT

I am sending WPML debug info and a screenshot with console error.

Kind regards

wpml-error.jpg
November 20, 2017 at 5:45 pm #1436208

Bruno

Thank you.

Yes. As Jörg posted, this is a bug in the WordPress 4.9. This issue persists even with WPML disabled. Unfortunately, I do not know when this will be fixed in WordPress core. Maybe in the next version 5.0.0.

As a workaround, you can change the WordPress interface to use English or Deutsch (but not the "Deutsch (Sie)"). To do this, follow the steps below:

- Click on the Users > Your Profile
- On the Language, select "English" or "Deutsch" (but not the "Deutsch (Sie)")
- And click on the "Update Profile" button

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

November 21, 2017 at 8:48 am #1436597

georgiaT

Thank you for your feedback, I have changed the selected language to English.