This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by alexandraL-7 3 weeks, 2 days ago.

Assigned support staff: Bobby.

Author Posts
September 24, 2019 at 11:51 am #4631233

alexandraL-7

I am trying to:
I have a multilingual website with redirection for each language to a specific language version. As we use German DE as main language and DE_CH as second language - user should be redirect to the Swiss language version. But this unfortunately does not work. User in CH always start with the German version.

Link to a page where the issue can be seen:
hidden link

I expected to see:
With a Swiss browser: hidden link

Instead, I got:
hidden link

Do you have an idea how to fix this? Thank you very much!
Alexandra

September 24, 2019 at 6:32 pm #4633573

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

please verify that you have activated the browser language redirection within WPML->Languages

i have created a custom language for swiss with de-CH as its default locale and it worked well with my browser set to German Swiss

hidden link

the above URL redirects to
hidden link

as expected

NOTE : i have attached the configuration used for the custom language bellow

September 24, 2019 at 7:52 pm #4633951

alexandraL-7

My issue is resolved now. Thank you!