Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by jamesT-17 1 year, 1 month ago.

Assigned support staff: Bobby.

Author Posts
October 2, 2018 at 3:55 am

jamesT-17

I am trying to: set my translated URL into website.com/cn

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link (translated url)

Instead, I got: hidden link (default)

Additional Notes:
Followed this instructions:
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

October 3, 2018 at 9:19 pm #2785753

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

When i visit your site i currently can view the front end as expected for both default language and secondary language.

This is a common false negative notice, and the best way to verify this is by visiting the front end.

if the front end is displaying as expected , then this is verified as false negative and you can continue using the URL Structure without problems

if you are seeing an error 500, blank page or error 503 in the front end and its resolved by changing the URL Structure then we will need to further inspect the issue.

There is no need to follow the steps here https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

you are getting the directory /zh-hans/ because that is the laguage code for the Chinese language .

in order to have the url shown as hidden link instead of /zh-hans/ you will need to go to WPML->languages->Edit languages

and add a new custom language with the language code "cn" .

once that is done please go to WPML->translation management-> batch duplicate your pages/posts from the "old" language to the new custom language.

let me know your results please.

October 11, 2018 at 7:25 am #2806923

jamesT-17

I'll try that. I'll get back to you once the issue is resolved or if I still need further assistance. Thanks 🙂

October 11, 2018 at 7:01 pm #2809572

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

When ready , if needed reply here and i will be notified

thank you !

October 16, 2018 at 4:44 am #2819666

jamesT-17

My issue is resolved now. Thank you!