This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 1 month ago.

Assigned support staff: Riffaz.

Author Posts
September 8, 2019 at 12:31 pm

alexanderM-60

I am trying to:
Show multiple languages in the dropdown

Link to a page where the issue can be seen:
hidden link

I expected to see:
Language switcher with 3 languages
Instead, I got:
Language switcher with just 1 language

September 8, 2019 at 12:50 pm #4531451

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Welcome to WPML Support forum.

Could you please confirm that you have completely translated your pages? If not, could you please translate it completely?

Also, could you please try to enable the 'Link to home of language for missing translations' option at WPML > Languages > Language switcher options section?

Please let me know how it goes.

Kind regards,
Riffaz.

September 9, 2019 at 10:09 am #4535857

alexanderM-60

It is still the same. For example, check this page: hidden link

September 10, 2019 at 6:50 am #4542313

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Many of your pages are just keep loading: hidden link
So I could not check your site properly.

This is because your site does not recognize your server memory limit and your wp memory limit is just 40 Mb : hidden link
These values are really not enough to ruyn WPML and other plugins, specifically when you use page builders.
Please ask your hosting provider to increase this to the maximum they can first.

Then disable all the third party plugins.
Follow the steps I suggested in my previous reply.

Let me know how the results, please after that.

Regards,

September 11, 2019 at 5:25 am #4550671

alexanderM-60

Thanks for the reply. I had set the memory limit to -1 for unlimited. Now there is a limit of 2048MB.

September 11, 2019 at 11:08 am #4552831

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I see you did not add any menu language switcher: hidden link in your site.
Then how/where your menu comes from? is this a custom menu?

Added a menu drop down to your footer : hidden link and that works fine in your pages: hidden link
So, this is something related to your theme the way the menus were built or the custom code used.

Let me know.

Regards,

The topic ‘[Closed] Language dropdown does not show other languages.’ is closed to new replies.