Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bobby 2 years, 11 months ago.

Assigned support staff: Bobby.

Author Posts
December 15, 2016 at 8:42 pm #1161634

kamalpreetS

I'm facing problems when uploading the flag icon and keep getting the following error: Fatal error: Call to undefined function mime_content_type() in /home/hhelpglobal/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/commons/src/wpml-wp/class-wpml-wp-api.php on line 13

December 16, 2016 at 12:32 am #1161737

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

based on the info at http://stackoverflow.com/questions/14809054/mime-content-type-function-not-working , can you please try to check the mime_magic extension. It's on or off?

You can can check your php.ini or look in phpinfo().
Does that help?

P.S are you using custom flags by any chance ?

December 16, 2016 at 7:05 pm #1162576

kamalpreetS

Hi Bobby, I'm using custom flags that's right. When uploading my custom flag it gives me that error.

December 16, 2016 at 10:48 pm #1162692

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi,

Thank you for confirming that !

Were you able to check the mime_magic extension. It's on or off?

If you are not too sure i can take a closer look just let me know and i will provide you with a private reply box for your sites credentials

December 17, 2016 at 12:05 am #1162714

kamalpreetS

Hi there,

No luck still. Can you please send a private reply box? Also, how can I change a language code? I want to make two versions of the site (homeworkhelpglobal.com/ca and homeworkhelpglobal.com/us and unfortunately a language Catalan uses the code "ca" but I want to use it for Canada.

Thanks!

December 17, 2016 at 1:08 am #1162731

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

For that you might have to delete the Catalan language from within the database (not recommened if you ever plan on using it if not please do a backup first before doing so)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

The topic ‘[Closed] Language Flag Not Uploading’ is closed to new replies.