Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Lauren 1 month ago.

Assigned support staff: Lauren.

Author Posts
November 5, 2019 at 6:25 pm #4892809

mattW-16

I am trying to: Go to English site, click on Espanol and then stay on the Spanish site.

Link to a page where the issue can be seen: Go to hidden link and click the flag and go to Espanol. However, you will see it redirect back to the English version again.

I expected to see: Go to hidden link and click the flag and go to Espanol. We expected it to stay there.

Instead, I got: After going to English and choosing Spanish, the site will redirect automatically back to English.

November 6, 2019 at 2:04 pm #4899103

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please see my previous private reply and let me know once the migration is completed. Thanks!

November 7, 2019 at 5:27 am #4902803

mattW-16

I tried to do this. Here is the error I'm getting:

Error! The URL specified is incorrect. Please check if your account is configured with hidden link

November 7, 2019 at 2:25 pm #4906753

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Sorry, it seems our test server was overloaded at the time of migration. Could you please try again and let me know if it is successful this time?

November 7, 2019 at 5:36 pm #4908861

mattW-16

I'll do this, but now I can't go back to the live site showing languages by domain. It seems to be going back to showing languages by subfolder. I was told that we could go back, and now a whole language is down! This is not good.

November 7, 2019 at 5:49 pm #4909069

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

To change it back, go to WPML -> Languages and select different domains per language. Then,resave the permalinks in General Settings ->Permalinks.

November 7, 2019 at 5:56 pm #4909097

mattW-16

I did that originally with no luck. I refresh the page and it goes back to the subfolders selection.

November 7, 2019 at 7:32 pm #4909743

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Are you checking the box to validate? If so, deselect that box and try saving again. Also, check in the browser console to see if there are any errors showing when you try to save. You should easily be able to change the URL format back and forth between the different options at any time.

November 7, 2019 at 8:12 pm #4909903

mattW-16

I had to uncheck validate on save for every language. Sorry about that. So, we are back to normal now. I'm going to retry the migration.

November 7, 2019 at 8:51 pm #4910091

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Okay, great. Let me know once the migrations is complete and I"ll continue there. Thanks.

The topic ‘[Closed] Language Flag Redirecting back to Original Link’ is closed to new replies.