This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I just need two languages French and English. After activating the plugin it shows only English and the other one is hidden. Why?

Solution: You need to disable hidden language option from WPML >> Languages >> Hide Languages section as you can see in the attached screenshot and this will show your French language: https://cdn.wpml.org/wp-content/uploads/2019/05/3921385-uncheck_hidden_language_checkbox.jpg?x34514

This topic contains 11 replies, has 2 voices.

Last updated by didierZ-2 4 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
May 30, 2019 at 8:29 am #3921307

didierZ-2

Hi, I have a big problem. I just need two languages French and English . after activating the plugin its show only English and the other one is hidden. Why should I told you guys every time? how you guys develop this plugin. I'm fed up with your service. trust me if I don't get the support as soon as possible I want a refund and I mean it. the most ridiculous service from your end. please have a look for why the French language is hidden. even I found no option to enable it. I attached an image of it

May 30, 2019 at 8:43 am #3921385

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Sorry for the trouble, you can show hidden language from WPML >> Languages >> Hide Languages section as you can see in the attached screenshot and this will show your French language.

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 30, 2019 at 8:57 am #3921463

didierZ-2

No i have done it before but still its not showing

May 30, 2019 at 9:02 am #3921481

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please try to clear your browser cache or try in different browser and let me know how it goes?

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 30, 2019 at 9:22 am #3921695

didierZ-2

you get it

May 30, 2019 at 9:36 am #3921745

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and checked WPML >> Languages page and it seems you have fixed this issue already as French language now showing fine as you can see in the attached screenshot.

Please note that I edited your topic because you had posted sensitive information (WP admin login info) in a public forum.

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 30, 2019 at 10:06 am #3921963

didierZ-2

Then I just have only English here sir.

May 30, 2019 at 10:18 am #3922041

didierZ-2

other pages are showing french flag but at the homepage why it's not showing. even I create a new page "Home test there is also showing only English there "

May 30, 2019 at 10:21 am #3922045

didierZ-2

And I put some text on another page it does not even translate well. what's wrong with this plugin. why its performance is so low

May 30, 2019 at 10:25 am #3922077

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To display other flag on frontend please make sure the content you are viewing on the front-end must be translated.

I have logged in to your site and duplicated home page in secondary language and now both flags are showing correctly as you can see in the attached screenshot.

Here are docs to translate/duplicate pages:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/
https://wpml.org/documentation/beginners-guide-to-site-translation/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

May 30, 2019 at 10:31 am #3922165

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Do you have any other questions regarding this issue? If you have other issues then please create a new ticket for each issue and we would be happy to help. This will help other users with similar problems to find solutions when searching the forum, We do not handle multiple issues in one same ticket as per support policy.
https://wpml.org/purchase/support-policy/

Thank you

May 30, 2019 at 10:34 am #3922181

didierZ-2

My issue is resolved now. Thank you!