This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by rossM-12 1 year, 6 months ago.

Assigned support staff: Bruno.

Author Posts
March 27, 2018 at 2:49 am

mikeE-8

I am trying to: Clicking the link for another language.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: Same page.

Also, in the admin, I'm created a Japanese version of an English Newsletter page. It makes me rename the slug from "apsf-newsletter" to "apsf-newsletter-2". I had the settings set to put links in a sub-dir. Also, after saving the Japanese version of the page, it creates an entirely new APSF Newsletter page in the english list of pages. On the front-end, when I click the link to go to the Japanese version on the front-end, it just keeps going to the english version.

March 28, 2018 at 2:34 pm #1559131

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

I saw the problem you're reporting. This seems to be a compatibility problem with some plugin you are using.

Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

March 28, 2018 at 2:55 pm #1559158

mikeE-8

Hello,

Yea, All in one migration is installed.

WPML was working before, but I don't think we added any other plugins before the URLs started breaking. We're curious to see what your investigation turns up.

Let me know if you need anything else or have any other questions.

March 28, 2018 at 11:57 pm #1559576

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. This problem is happening because both posts and pages have been marked to be not translatable.

On the WPML > Translation Management > Multilingual Content Setup > Post Types Translation, note that "Posts" and "Pages" are marked as "Not translatable". I'll attach an image for you to see.

As you want to translate these pages, these options should be like "Translatable". Following these steps, I fixed the problem on your site.

About the slug, you can change this in the secondary language by accessing the edit page and switch to the secondary language (Japanese). Then click to edit the slug. I'll attach an image for you to see.

By following both steps, this is working correctly on your site. Please, could you check?

Thank you.

March 29, 2018 at 1:30 am #1559617

mikeE-8

Thanks Bruno, that worked great!

March 29, 2018 at 2:28 am #1559632

mikeE-8

Hi Bruno,

I had a quick follow-up question.

On our Articles custom posty type, we have a taxonomy for "article-type", where multiple types can be selected. However, on the translation of the articles, only 1 article-type is shown and selected, even if there were multiple article types shown and selected on the English version.

Here is an example: hidden link

The article types in english that are chosen are:
- Announcement
- Article
- Dear SIRS
- Featured
- Historical Perspective
- Top Ten
(And there are more options available.)

But on the Japanese version, only "Article" type is shown and checked.

How can we show all of the choices on the translated version?

Is it possible to make it so we can choose "Article" and "Featured" on the translated version, and uncheck others?

Thanks,

March 29, 2018 at 7:35 pm #1560477

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I noticed that these taxonomies are not translated. Please follow the steps below:

- Click on the WPML > Taxonomy Translation
- Select the "Article Types"
- Translate the desired taxonomies
- Open the page again and update the original content
- Edit the translation and update the content

This should solve the problem with taxonomies.

Thank you.

March 30, 2018 at 4:16 am #1560647

mikeE-8

Thanks Bruno,

That worked great!

I had one more issue, but let me know if I should open a new ticket.

I setup added the Language Switcher as a widget to "Default Page Sidebar". I customized how it looks on the WPML settings page.

Then on the Widgets page under Default Page Sidebar, I used Jetpack to change the visibility so the Language Switcher widget only shows up the "Newsletter" page and all children pages.

After clicking save, this overwrote the custom settings of Language Switcher. When I go back to the WPML settings page to re-customize the language switcher, it overwrites the visibility settings I set on the widget page.

I seem to be stuck in a loop, and was wondering if there is a way to get the Language Switcher and Jetpack to work together?

March 30, 2018 at 7:16 am #1560699

mikeE-8

Hi Bruno,

I had a quick follow-up that might be related to the Language Selector, but I'm not sure. It's weird things happening with sidebar widgets on translated pages.

We have a number of menus setup, and added them as sidebar widgets to various pages. 2 weird things are happening.

1. A menu for "About APSF" is showing up on translated pages in the sidebar, but the widget hasn't even been added to the "Newsletter Page Sidebar" on those pages.
Example: hidden link
I expected to see this sidebar menu: hidden link
The translated page is erroneously pulling a menu that starts with "Mission and Vision", (the menu name is "About APSF"), but in the admin Widgets page under "Newsletter Page Sidebar" the "About APSF" menu isn't there in English or Japanese.

2. This could be related- I noticed when I switch to Japanese in the admin, and look at the widgets page, then select "Visibility" and "Show if" and select "Page"... the list of pages stops at "APSF Newsletter Archives". (screenshot attached). That seems like an error, because there are many more pages that aren't visible. All the pages show up in the dropdown on the English version.

Anyway, could be plugin conflicts, but I'm wondering if you have any ideas for troubleshooting since the pages/widgets/sidebars affected are using WPML?

March 30, 2018 at 10:29 pm #1561256

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Yes, please. As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.

March 30, 2018 at 11:44 pm #1561280

mikeE-8

Sorry, I thought this was a private support thread. Can you please remove the links from posts. Thanks you.

March 31, 2018 at 1:14 am #1561303

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. The links are only visible to registered users. Unlogged users see the "hidden link" message. I've changed the name of your site to just "site.org".

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

April 2, 2018 at 6:08 pm #1562530

mikeE-8

Thanks Bruno!

May 22, 2019 at 7:16 pm #3868867

rossM-12

I am having this problem as well. I followed the instructions above but can't seem to get the home page link to work. If I type in the ?lang=fr it works just fine, the link doesn't contain the language query item.