Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The language switcher is not showing up on my homepage, even though I have translated the homepage. Also, how can I change the CSS for the language switcher?

Solution: The language switcher was not working because the home URL was not set in your database. Once I set the URL, the language switcher works perfectly.

Also, for changing the font, you can add some custom CSS to override the default settings. In the Appearance -> Customize -> Custom CSS section I changed the font to #666666 but you can add or edit any CSS there.

This topic contains 9 replies, has 2 voices.

Last updated by adrienm-5 2 years ago.

Assigned support staff: Lauren.

Author Posts
January 31, 2018 at 5:55 pm

adrienm-5

Hello,

I'm opening a new ticket regarding the issue Im having with your plugin.

The languages are not showing up properly in the menu. I set up both English and French but only English is showing up on the homepage Ace.

The Ace page is not showing up in the French menu so I can't add the page even though it has been translated.

Also I set up the color for English and French as Grey #666666 but it is still showing black...

Can someone please look at the settings?

February 1, 2018 at 5:39 pm #1504462

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I can see the Ace page in the French menu options. You may need to click on All Pages, but it shows for me in Recent, as well. Please see attached screenshot.

You mentioned "Also I set up the color for English and French as Grey #666666 but it is still showing black...". Can you tell me what you are trying to set to grey? Do you mean the font? And where are you setting this information?

Lastly, in regards to the menu issue, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, does the language switcher work correctly?

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

February 2, 2018 at 1:47 am #1504813

adrienm-5

Hi Lauren,

I cannot add the debug information for some reason. I mentioned it in the other post.
I have had so many issues with that plugin. The other agent asked my authorisation to log in to my account and check what's going on. I told him to go ahead, provided all the login information but he did not do it.
Could you or someone look at it? The website is backed up every 24h.

Now I see the Ace page, I added it BUT I cannot click on the French language when I'm on the Ace page. The default text color and size is too similar to the menu. Also I added flags but I do not see them.

I have added screen shots.

February 2, 2018 at 2:13 am #1504828

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

What were the results with deactivating plugins and changing to a default theme? Did the language switcher work as expected with those settings, or did you have the same problem?

If you are unable to test this on your live site, To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

February 2, 2018 at 11:28 pm
February 5, 2018 at 3:16 pm #1507334

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending the Duplicator files. I found that the language switcher was not working because the home URL was not set in your database. Once I set the URL, the language switcher works perfectly.

Also, for changing the font, you can add some custom CSS to override the default settings. In the Appearance -> Customize -> Custom CSS section I changed the font to #666666 but you can add or edit any CSS there.

As for the new layout issue, since the original issue is resolved may I kindly ask you please to open a new ticket for this question? This will also help other users with similar problems find solutions when searching the forum as well as we avoid mixing lots of questions in one ticket.

Thank you for your understanding.

February 5, 2018 at 11:23 pm #1507881

adrienm-5

Hi Lauren,

I don't see the code in the CSS. Also there is no a:hover color anymore which I had set up before. Now they both look grey (selected or not) by default so we don't know which one is selected.

February 6, 2018 at 4:44 pm #1508894

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please see attached screenshots. The custom CSS is in Appearance -> Customize -> Additional CSS. You can change the color and add the a:hover here, also.

February 6, 2018 at 10:43 pm #1509235

adrienm-5

Thank you. I found it. Do you think you could help with a:hover? I tried something (cf attached) but it didnt work

February 7, 2018 at 3:04 pm #1510197

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I have added the following CSS which adds the hover:

li.wpml-ls-menu-item a:hover span {
    color: #666666 !important;
}

Please let me know if you need any further assistance and I will be happy to help.

February 8, 2018 at 1:43 am #1510765

adrienm-5

Thanks so much for your help.