This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.02 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Raja Mohammed 2 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 30, 2019 at 3:42 pm #4309391

janH-22

I have translated a Dutch a one page (elementor) website to English. However when turning on the language switcher "English" the page is not turning up.

July 31, 2019 at 4:51 am #4311455

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

1) Please let me know the URL where the issue can be seen.

2) It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

July 31, 2019 at 8:09 am #4312705

janH-22

The debug information is very little (https://pastebin.com/M3d8WFUV).
The website is hidden link

August 1, 2019 at 4:20 am #4318671

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This seems like a conflict or a compatibility issue. In a test environment or after securing a backup if your site and database,
- Disable all non-WPML plugins except Elementor check if the issue still persists.
- Change the theme to any of WordPress default theme, does it solve your issue?

Please let me know the results. If you still have issues please share temporary access to your site let me have a closer look into your issue. I have enabled private fields for this purpose.

Kind regards
Raja

The topic ‘[Closed] language option not showing up, cannot find translated page’ is closed to new replies.