This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 3 voices.

Last updated by Vincenzo 1 year, 5 months ago.

Assigned support staff: Vincenzo.

Author Posts
May 12, 2018 at 10:25 pm #2102889

hugoR-10

I am trying to:
Change the language order to: French, English

Link to a page where the issue can be seen:
hidden link

I expected to see:
Language order: French, English
Instead, I got:
Language order: English, French

May 13, 2018 at 1:09 pm #2105714

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

While one of my teammates takes care of your case I will provide you with the first debugging steps.

I have visited your site and I see that you are using a dropdown menu. For this kind of menu, those settings does not apply as it will show always on first place the current language.

If it was not the case and while another supporter takes personal charge of your situation, could you let us where is located the problematic language switcher?

Let us know if it helps.
Andrés

May 13, 2018 at 4:11 pm #2106977

hugoR-10

Thank you Andres.

1. Ok. I understand that to show the opposite language first is not possible using a DropDown menu. Do you have any suggestions for what I wish to achieve?

2. I would like to show the opposite language at all times. For example. If I am on the English site, only a French link shows in the switcher. Is that possible?

Thank you,

May 14, 2018 at 11:31 am #2117808

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello there,

I would like to take care of your ticket from now.

You can try these steps:
- Go to WPML -> Languages
- Edit the related language switcher
- Select the "List of languages" option instead of Dropdown
- Deselect the "Current language" option
- Save

Please let me know if this answers your question or if you need further details.

Thank you