This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Andreas W. 3 months ago.

Assigned support staff: Andreas W..

Author Posts
June 20, 2019 at 10:48 am #4059059

henkC

Hi

Apparently my previous support ticket got closed probably due to inactivity. (https://wpml.org/forums/topic/language-parameter-in-middle-of-url/)
The issue still isn't resolved and I'd like to resolve this asap.

The latest suggestion was to give provide you with credentials to log into our site and fix it. Now, my boss is really anxious to lose anything or having to fix things once your done. This is why I wonder whether it would be possible to make some kind of arrangement where you take over my computer (this way I can see what you're doing and I can interrupt if I see something that would cause any damage to the site) with TeamViewer or something like it and perform the fix.

Sorry for the inconvenience

Greetings

June 20, 2019 at 11:28 pm #4063565

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Sadly, we can not offer to work with TeamViewer but we can offer you to provide a download link to a Duplicator package. This way we can migrate easily and I can debug local.

https://wordpress.org/plugins/duplicator/

Duplicator is free to use for site backups up to 500MB. You further can set filters at the first step of the package install in order to exclude cache files, backups and even uploads. Onlz consider to not add upload to the packe if the issue is not realted to anz media files.
Duplicator will create two files, an archive.zip file and a file called installer.php.
hidden link

Make sure to provide both files. The private box is enabled in order to provide the download link.

Kind regards
Andreas

June 25, 2019 at 1:05 am #4080229

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry for the dealy on answering.

I was able to install the duplicator package on localhost and started debugging. Once accessing the wp-admin the plugin WooCommerce Product Bundles caused a 500 error. I disabled the plugin and proceeded.

Once I accessed the wp-admin there been various errors visualized that are related to the Flatsome Child Theme. Switching to the default Flatsome theme caused similar errors. I switched to the default Twenty Nineteen theme without any errors.

Now, in regards to the URL issue, on my test the Dutch page for the category audio looks like this:

hidden link

This is indeed a correct URL with the respective slugs. On your live site the same slug is visualized liek that:

hidden link

Here /?lang=nl refers to the languag parameter and is placed at the end. You further could here change the site URL structure to language in directories. You find this option at WPML -> Languages -> Site URL structure. With this option the above mentioned URL would result in:

hidden link

Here /audio-nl/ refers to the literal translation for this category. You can find it at WPML -> Taxonomy Translation -> select product categories from the dropdown and translate.

Is this the language parameter you are referring to?

Kind regards
Andreas

June 26, 2019 at 9:09 am #4090689

henkC

Hi

I'm guessing all of the problems you're having on the localhost testing site, have something to do with the duplicating process because on the live site we only have problems with the translation part of the url being in the middle of the url instead of at the end.

Now, your colleague made the same suggestion on my previous ticket but as I've said then, that isn't possible because we run several adds on google etc so if we would change our url structure, all of those links would be broken.

Your collegue did actually fix the problem but he did so on the staging site (As you can see in the previous ticket, I made a staging site, which is an exact copy of this site, so he could test everything). But when I tried applying the fix on the actual site, it still failed.

As I've said before, I can grant you permission on our actual live site but then I'll need to know for sure you won't make major changes to the site that would effect the site in a bad way. Or if you'd like, I can set up a staging site again.

Thanks

June 26, 2019 at 4:19 pm #4094043

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry, I did not see the issue right away:

I now entered the homepage of your live site. Change the language to Dutch. Scrolled down to the section Products and selected Platenspelers.

I get redirected here:

hidden link

instead of:

hidden link -> repectively for the English category of turntables.

This issue is very likely caused to a compatiblity issue between WPML and another plugin or the theme itself.

I was going to try to run the site on minimal setup but for some reason this is hard on the localhost migration as it does not even start without disabling all plugins. Further, as you been guessing there seem to be database issues after migrating the site.

It would be helpful if you could provide acces in order to make some tests, only be deactivating plugins and changing the theme without taking any edits on settings, if possible?

I have enabled the private box in order to provide access. Make sure to take a backup of the site and database before providing access. A staging site surely would be ideal!

Kind regards
Andreas

June 27, 2019 at 2:09 pm #4100729

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

A staging is perfect, thank you.

Could you please provide the directory credentials in order to reach the wp-login.php page?

Kind regards
Andreas

June 27, 2019 at 2:38 pm #4100905

henkC

Hi

I'm not sure what you mean but you can find the wp-login.php file under /staging/1/wp-login.php

to log into the site u can use:
**CREDENTIALS REMOVED**

Thanks

June 27, 2019 at 6:29 pm #4102127

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

I am referring to the login and password requested in order to optain access to the wp-login page. See screenshot.

Kind regards
Andreas

June 27, 2019 at 11:42 pm #4103207

henkC

Hi

Oh, I'm sorry I forgot to give you those credentials.
**CREDENTIALS REMOVED**

I'm sorry for the inconvience.

Greetings

June 28, 2019 at 4:01 pm #4109307

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please go to WooCommerce -> WooCommerce Multilingual -> Categories -> Hierarchy Synchronization.
You should see at the bottom an option called: "Synchronize product category assignment in content". Run it and another option should appear called:
"Update products categories for alltranslated products".

On you staging this solved the issue with one exception. It works all perfect on the default Flatsome Theme but once I change to the Child theme the site breaks and I am not able to verify if the URL issue is solved.

Do you have any idea what might cause the issue as it might very possbily be realted to custom code inside of the child theme files?

Kind regards
Andreas

July 4, 2019 at 8:35 am #4141243

henkC

Hi

It didn't work and we don't have any custom code so that can't really be the issue.
Also, any idea why the solutions you try on the staging site work on there but when I do the exact same on the live site, it fails?

Greetings

July 4, 2019 at 9:35 am #4141987

henkC

EDIT TO THE TICKET

I've recently noticed that when looking at the English site, the product-categories url's have 2 slashes (/) where the language param would be. I know it's normal that there isn't a language param on the English site, I just find it strange that there are 2 slashes instead of 1 in the exact place where the language param is placed (wrongly) when looking at the url in the other languages.
I have no clue this makes it any easier to determine the cause of the problem but here you go.

Thanks

Greetings

July 4, 2019 at 2:23 pm #4144409

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

All taxonomies can further be translated and synchronized, by going to WPML -> Taxonomy Translation.

I synchronized the product categories again at WPML -> Taxonomy Translation -> Product Categories.

Then I checked the Fornt-End and the error was not present.

hidden link

Let me know if you need further assistance.

Kind regards
Andreas

July 5, 2019 at 1:50 pm #4151753

henkC

Hi

I've literally tried all those steps nearly 50 times now but nothing seems to work. May I ask where you performed that solution? Was it on the staging site or our live site?

Every time I perform 1 of your solutions and I go to my homepage, scroll down and hover over a product category, the problem still persists. The language param is still in the middle of the url.

I have literally searched the whole plugin from front to back for anything that could help me but no luck.

Greetings

July 5, 2019 at 7:33 pm #4153811

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I only had acces to the staging site but the credentials are not valid anymore. It seems the password got changed.

I am not sure why after after revisintg the Front-End I can see that the issue is persising or appeared again.

hidden link

Please provide access again for further investigations.

Kind regards
Andreas

The topic ‘[Closed] Language parameter in middle of URL Follow up’ is closed to new replies.