Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Different domain per language WPML's option doesn't work.

Solution: Check that your domains are pointing to the correct environment. For this disable WPML, now you should display the same content in both domains? (Without any redirection).

Relevant Documentation: https://wpml.org/faq/server-setting-for-languages-in-different-domains/

This topic contains 3 replies, has 2 voices.

Last updated by Andrés 3 years, 11 months ago.

Assigned support staff: Andrés.

Author Posts
February 22, 2016 at 2:51 pm #820158

Patrick

I am trying to:
Set up a different domain per language.

URL of (my) website where problem appears:
See debug info for the domain name, as I do not want it public. Essentially hidden link for the English and hidden link for the French.

I expected to see:
The French version when I visit hidden link

Instead, I got:
A double-301 to the english version (www.example.ca/entreprise/ -> hidden link -> hidden link)

Steps to duplicate the issue:
Visit hidden link

Things I've tried so far to resolve the issue:
1) Save permalinks (multiple times, and after each step)
2) Set French to /fr/ and ?lang=fr, both of which work
3) Verify .htaccess is not redirecting
4) Disable plugins and try twenty-fourteen theme
5) Do updates on WordPress and plugins
6) Change redirect to fr.example.com (does not work)

What's going wrong? Thanks!

February 23, 2016 at 11:05 am #820961

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Patrick,

Welcome to WPML support forum.

1. Let's check if your domains are pointing to the correct place. If you disable WPML can you display the same content in both domains? (With any redirection).
- hidden link
- hidden link
https://wpml.org/faq/server-setting-for-languages-in-different-domains/

2. It would be good if you can provide me the WordPress debug.log (not WPML debug informations). Please check this page for instructions
https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Regards,
Andrés

February 23, 2016 at 1:15 pm #821141

Patrick

Thank you! Point 1. was the answer! I had my .ca set as a pointer so I changed it to an alias. Strange that it used to work and stopped working, but I'm glad to have it fixed again.

Thanks again!

February 23, 2016 at 1:43 pm #821176

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I'm glad to know it is solved, Patrick.
Have a nice day!
Andrés