Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months, 4 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 9:17 pm #4286115

michaelF-64

I am trying to:
Use the language query parameter to handle multiple pages

* Switch to Spanish
* Visit 'Conoce a Cory' or 'Involúcrate'
* The url will include `?lang=es` in the middle of the url i.e. `hidden link`

Link to a page where the issue can be seen:
hidden link

I expected to see:
`hidden link`

Instead, I got:
`hidden link`

July 25, 2019 at 11:20 pm #4286231

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Regarding your issue, please, try the following:

1 - Disable all the plugins except those related to WPML itself.

2 - In your WordPress Dashboard > Settings > Permalinks choose the 'Plain' option, save it and visit your website homepage.

3 - Now, choose your previous chosen option for your permalinks settings, I recommend the 'Post name' option as a clean choice for your url structure.

4 - Activate one plugin at a time always testing your spanish page.

Please, let me know if it helps. Have a nice day.