This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Dennis 7 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
March 7, 2019 at 2:27 pm #3284894

albertoB-2

I am trying to: add ?lang=en to an existing page like hidden link

Link to a page where the issue can be seen: hidden link

I expected to see: the page in English

Instead, I got: Page not found

March 8, 2019 at 8:31 am #3290014

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I noticed that the english translation for the page hidden link is hidden link

It seems that you would like to have the same slug for your english translation. So you're english url for that page would be hidden link

If that's the case, For the custom page/post to have the same slug, go to WPML > Settings > Translated documents options > and select "Translate (this will include the slug in the translation and not create it automatically from the title)"

After this option is saved now you can go to your secondary language post/page and within edit by the permalink you can click edit and edit the slug.

Does it help? Please let me know.

Kind regards,
Dennis