Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The language switcher doen't work correctly on a given page.

Solution: Issue was caused by a rogue 410 redirect added to Yoast (path specified was /wisconsins-global-reach/), which is outside of what we normally use for handling redirects.

Relevant Documentation:

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks, 5 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
November 5, 2019 at 6:03 pm #4892465

kellyL-6

I have built out some test translation pages.

These can be accessed at these links (PLEASE NOTE - there is no content currently on these pages, on the FR page there is some test content):

hidden link
hidden link
hidden link
hidden link
hidden link

If you access the site via any of these links, you can use the language select dropdown menu to navigate between the translated pages and the menu works as intended (if you click to the english page -- the issue mentioned below will occur and the links for the translated pages will change).

*** see screenshot translated-page.jpg (this page was accessed directly by the link) -- Note that Deutsch is highlighted in the language select menu, and then note the hover link in the bottom left hand corner of the screen shot. The correct link is displaying and when clicked, I am taken to the translated page.

HOWEVER --

If you are starting on the default language page: hidden link

The links in the language select menu all link to hidden link and the translated page links mentioned above are not accessible.

*** see screenshot default-language-page.jpg -- Note that French is highlighted in the language select menu, and then note the hover link in the bottom left hand corner of the screen shot. The incorrect link is displaying on hover - the link that is showing is default page link and not the translated link.

Why is this happening? I have tried referencing multiple other threads, flushing permalinks, following the troubleshoot steps, clearing both site cache and WPML cache -- but nothing has been working. Am I missing some setting? Let me know if I can provide additional information.

November 8, 2019 at 12:33 pm #4913299

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

November 12, 2019 at 9:45 am #4930235

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for the information provided.

I tried to update the outdated plugins in the test site but it went down. Could you restore the test site and updated all outdated plugins, themes and the core and double check if the issue persists?

Regards,
Carlos

November 12, 2019 at 3:19 pm #4932755

kellyL-6

Can you provide more information as to what you mean by "went down"? I am currently able to access both the front and back end of the site, and do not see any fatal errors in the host log.

I will restore a backup and proceed with updating all plugins.

At this point in time, a Theme update will not be possible.

November 12, 2019 at 5:15 pm #4933749

kellyL-6

Plugins have been updated and the site has been backed up again.

November 13, 2019 at 9:06 am #4936641

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for restoring the site and updating the plugins.
When I updated the plugins I just got a WSOD, no errors or warnings.

Now I'm trying to log in the site but the credentials don't work anymore. Could you double check the credentials and edit your private message if necessary?

Regards,
Carlos

November 13, 2019 at 3:17 pm #4940665

kellyL-6

ahhh the back up restoration removed your user.

The user has been restored with the same user and pw in the private message.

November 14, 2019 at 10:13 am #4945357

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for restoring the credentials.

This time I was able to log in to the site again, and after taking a deeper look at the issue it seems that this is a custom language switcher. Could you describe the steps you followed in order to create, activate and/or edit this language switcher.

Regards,
Carlos

November 14, 2019 at 8:51 pm #4949845

kellyL-6

Here is my process:

I created a custom widget area titled "Language Select", and am displaying the widget area within a template part. The WPML Language switcher is assigned to display within this custom widget area within the WPML settings. There is some basic styling to the language select menu, but there is no additional code changing any of the functionality provided.

I created the language switcher within the WPML settings.

WPML -> Settings -> Widget Language Switcher and then set the widget position to the custom widget area titled Language Select. Any edits or settings to the switcher were all done in this area of the WPML plugin settings.

Did I do something wrong creating the language switcher? What are the correct steps to setting this up so it works correctly?

November 15, 2019 at 11:36 am #4953351

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for your feedback.

The steps you followed seems to be correct. As a test I added a language switcher at the footer of the theme and the issue persists, which means that the issue might be caused by some kind of conflict between WPML and a third party functionality.

In this scenario I would like to ask you to follow this steps:
- Create a full backup of the site for security reasons.
- Update all outdated plugins and the theme to their latest version. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exists.
- Create a new test page -> Translate it and double check if the issue persists.

If the issue persists then:
- Deactivate all plugins except WPML ones.
- Activate a default WordPress theme, like Twenty Nineteen.

If the issue disappeared then start activating the theme and the plugins one by one until the issue appears again.

Could you tell me the results of the steps above?

Regards,
Carlos

November 18, 2019 at 3:00 pm #4966135

kellyL-6

Looking into this today, will report back with results.

November 18, 2019 at 3:07 pm #4966163

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

Take the time you need. Thank you for keeping me updated.

Regards,
Carlos

November 18, 2019 at 3:43 pm #4966485

kellyL-6

Issue is caused by a plugin conflict with Yoast SEO, while Yoast is deactivated, translation menu links work as intended and translated content is display correctly.

Continuing to look into what is causing this.

November 18, 2019 at 3:49 pm #4966565

kellyL-6

This issue has been resolved, thank you for you assistance.

Issue was caused by a rogue 410 redirect added to Yoast (path specified was /wisconsins-global-reach/), which is outside of what we normally use for handling redirects.

November 18, 2019 at 3:51 pm #4966569

kellyL-6

My issue is resolved now. Thank you!