This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by sandroS 5 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
May 1, 2019 at 7:23 am #3716517

sandroS

I am trying to:
When i change the language with language selector change the admin default language too.

Link to a page where the issue can be seen: hidden link (admin section)

I expected to see (croatian language is default):
Sva (43) | Moja (34) | Objavljena (34) | Skice (9) | Smeća (2)

Instead, I got (switch to germany - pages):
Alle (43) | Meine (34) | Veröffentlichte (34) | Entwürfe (9) | Papierkorb (2)

More:
Default language set in WPML is Croatian, when the language is changed the admin menu is change language too. In admin profile the language is post to Site default and the editing language is unchecked. When i change the language with language selector change the language in the admin profile. See the image.

May 1, 2019 at 9:32 am #3717237

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Sandro,

Thank you for reaching out the WPML support!

Can you try to check the Set admin language as editing language., save the changes, and uncheck it back, please? Maybe there's something wrong with the value saved to the database and this little changes will make it go back to normal. If the problem is still there once you do this change, I'll need access to the dashboard area of your site so I can have a closer look at the issue.

Thanks,
Radu

May 1, 2019 at 9:42 am #3717285

sandroS

I hoppe that the access datta is private ?

May 3, 2019 at 7:10 am #3731387

sandroS

Hello,

Did you see the problem? We stopped working and wating for your answer to our problem. So, can you please give me some deadline for resolving this problem.

Best regards,
Sandro

May 3, 2019 at 8:10 am #3732017

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Sandro,

I checked your website the moment you replied me back with the credentials. I looked at all the settings and, even though everything looks fine, the Editing language option doesn't seem to be counted. Can you deactivate all the plugins except for the WPML ones, activate a default theme (like Twenty Nineteen), and tell me if this problem is still available, please? This way we can make sure that this is not a problem caused by some incompatibility between WPML and the other plugins you're using.

Thanks,
Radu

May 3, 2019 at 12:52 pm #3734333

sandroS

Hello,

I made this and got a conclusion that the problem is Hotel Booking - Property Rental WordPress Plugin (hidden link). This plugin is declarated like compatibile one with WPML. When the plugin is not active the page works normaly. What can I do now?

Thank you

May 3, 2019 at 1:25 pm #3734675

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Sandro,

I had a look at this and it seems that the last time that my team checked the compatibility with Hotel Booking was over a year ago. A lot of new versions were released and this might be an issue that appeared lately. In this case, is there any chance that you could send me an archive with the latest version of the plugin so I can test this out on my side and report the issue to my colleague, please? This way, my colleagues will reach out to the plugin authors and work together to get things fixed. I'm asking you for the plugin archive so I don't wait for the plugin authors to respond me back (and speed up the whole testing and fixing).

Thanks,
Radu

May 10, 2019 at 3:37 am #3781111

sandroS

My issue is resolved now. Thank you!