This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Links of the Language Switcher are not being generated

Solution: In this case, the problem was the server configuration. Some possible solutions: - Update all WPML plugins & WordPress core. - Update PHP version - Increase the PHP memory - Check WPML and WordPress Minimum Requirements WPML: https://wpml.org/home/minimum-requirements/ WordPress: https://wordpress.org/about/requirements/

This topic contains 11 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 4 months ago.

Assigned support staff: Diego Pereira.

Author Posts
May 14, 2018 at 4:01 pm #2124262

cidikleid

Tell us what you are trying to do?
I want to activate the languages ​​listed in the home menu and you are not clicking because I have already made all the pages, just not giving to click!

Is there any documentation you are following?
No, I did the translation as wpml indicates
Is there a similar example that we can see?
I translated the 3 home pages of the languages ​​that I will release, but at the time of selecting they will not, not to click, but if I put the link from home it will.
What is the link to your site?
egosssteste.com

the page translations:
hidden link
hidden link
hidden link

May 14, 2018 at 7:11 pm #2126226

cidikleid

ainda não conseguir resolver meu problema

May 14, 2018 at 7:56 pm #2126576

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @cidikleid, welcome to our support forum 🙂

I checked your website and found that the language switcher links are without the "href" attribute, which prevents it to work. To proceed, I need an answer to some questions:
- How did you add the language switcher to the menu? You used the "WPML -> Languages -> Menu language switcher" option? Or did it another way?
- Looking at the code on your website, you're apparently using a mega menu plugin. What is the name of this plugin? Or has it already integrated with the theme?
- What is the theme name?

You can also try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with your theme that is causing the problem.
IMPORTANT Please backup a working copy of site files and database before continuing.
- Update all WPML plugins & WordPress core.
- Then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

All the best,
Diego

May 15, 2018 at 12:29 pm #2138603

cidikleid

yes I added it by WPML -> Languages ​​-> Menu language alternator ", I am using the Emporos fashion theme, all other page works friend only the home will not, where I put the href in the link? that ai sure that will work the problem was I did not find the place to put it.

May 15, 2018 at 5:35 pm #2145678

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi @cidikleid,

The problem seems to be connected to the menu. The hrefs are configured automatically, but apparently something is removing it, perhaps by a plugin or theme (or something related).

Please do the following:
- Add a language switcher to the footer and test if it works outside of the header menu.
- Update all WPML plugins & WordPress core.
- Change to a default theme (like Twenty Seventeen), disable the other plugins and see if it works in the header menu.

PS: We recommend that you back up your website before.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Regards,
Diego

May 16, 2018 at 1:30 am #2148960

cidikleid

segue o acesso para o site para vocês analisar o motivo do erro
[CONTENT REMOVED]

May 16, 2018 at 12:55 pm #2157391

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

[Portuguese]
Oi @cidikleid, Como este é o forum inglês, o ideal é que eu me comunique em inglês para ajudar outras pessoas que também possam estar com o mesmo problema no futuro, tudo bem? Porém se quiser pode falar em português que eu entendo (sou Brasileiro também).

[english]
I needed to remove your login data from the last reply. Please do not submit sensitive data in the public forum. I'll enable private replies to this topic if I need to send sensitive data.

We usually do not access or edit your site directly because of security concerns. In these cases we ask for a copy of your website so that we can try to reproduce the problem on our server.

Here is the link explaining how to send us a copy of your website: https://wpml.org/faq/provide-supporters-copy-site/

Please send the files through the private field.

Regards,
Diego

May 17, 2018 at 6:29 pm #2181027

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @cidikleid!

Sorry for the delay, our queue is bigger than usual.

I tried to download it through the link you sent me, but it did not work.

I logged into your website through the data you gave me and installed Duplicator PRO. Through it I generated a new package and managed to copy your website to my local server.

To my surprise the menu worked normally on my server, without me modifying anything. Please take a look at this video that I recorded of my screen: hidden link

So, it seems to me that the problem is with some configuration of your server.

Please do the following:
- Contact your hosting server and ask to upgrade PHP to version 7 (your current version is 5.6.30).
- Also ask to increase the PHP memory

On my server, after enabling wp_debug, I also found the following PHP notice:
Notice: Undefined property: stdClass :: $ data in C: \ xampp \ htdocs \ debug1 \ wp-content \ plugins \ emporos-addon \ emporos_addons \ emporos_instagram_grid.php on line 218

You can also try removing the instagram feed from the index to fix this PHP notice.

All the best,
Diego

May 18, 2018 at 10:18 pm #2192423

cidikleid

Olá amigo joguei pra uma nova hospedagem , realmente voltou funcionar mais aproveitando o suporte já quero saber sobre um problema que estou tendo no atributos , não está indo já fiz de tudo pra poder aparecer nas outras linguagens e não está indo e as configurações estão corretas , pode me ajudar ?

May 21, 2018 at 12:23 pm #2201280

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá @cidikleid, que bom que funcionou. Claro que posso te ajudar!

[english]
Você se refere aos atributos de produto do WooCommerce? Para traduzi-los, você irá precisar da extensão Woocommerce multilingual, disponivel na sua página de downloads (https://wpml.org/account/downloads/).

Este é o link da documentação: https://wpml.org/pt-br/documentacao/projetos-relacionados/woocommerce-multilingual-gerencie-sites-de-comercio-eletronico-em-varios-idiomas/

Após ativa-lo, vá até Woocommerce > Woocommerce Multilingual > Attributes e experimente traduzi-los.

Se ainda assim não funcionar, vá para Woocommerce > WooCommerce Multilingual > Products, clique em seu produto e veja se o atributo é exibido na tabela para tradução.

[english]
Do you mean the product attributes of WooCommerce? To translate them, you will need the Woocommerce multilingual extension, available on your downloads page (https://wpml.org/account/downloads/).

This is the documentation link (english version): https://wpml.org/documentation/related-projects/woocommerce-multilingual/

After activating it, go to Woocommerce> Woocommerce Multilingual> Attributes and try translating them.

If it still does not work, go to Woocommerce> WooCommerce Multilingual> Products , click on your product and see if the attribute is displayed in the table for translation.

All the best,
Diego

May 25, 2018 at 10:57 pm #2231834
cidikleid

então amigo, resolvi as dúvidas acima , agora preciso que me ajude em um pequeno problema , pois comprei 2 domínios pra mim , .com e .com.br , pois br Brasil e .com outros países , queria linkar no br o domínio .com , e no .com lincar o .com.br para Brasil, como eu faço essas alterações ?

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-how-to-configure-multiple-domains-for-languages/

May 28, 2018 at 12:28 pm #2238496

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá @cidikleid,

Como o problema deste ticket já foi resolvido, criei um novo ticket para o novo problema e irei marcar este como resolvido.

Por favor verifique o novo ticket com as novas respostas.

Atenciosamente,
Diego