This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by hlaingM 5 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 20, 2019 at 7:26 am #3649667

hlaingM

I am trying to: install and incorporate the language switch

Link to a page where the issue can be seen: hidden link

I expected to see: language switch in the topbar and the footer

Instead, I got: nothing shows up

(image attached)

April 21, 2019 at 6:26 am #3651747

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Welcome to WPML Support forum.

Could you please confirm that you have completely translated your home page? If not, could you please translate it completely?

Also, could you please try to enable the 'Link to home of language for missing translations' option at WPML > Languages > Language switcher options section?

Please let me know how it goes.

Kind regards,
Riffaz.

April 21, 2019 at 9:00 am #3651917

hlaingM

Hi

Thank you for your reply. Yes, the language switch (icon) now appears with my following of your instruction. I don't intend to translate all the contents into the foreign language. Rather, I plan to leave some of them as they are in English when the language is switched to the foreign language.

Now, when I or a user clicks the foreign language icon, I receive the following message "Oops! That page can't be found.".

Could you please help me with that issue? Thank you very much.

April 22, 2019 at 5:49 am #3653945

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are missing duplicated contents/pages.

Please follow the steps to show duplicated contents in your secondary language: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Let me know how it goes.

Regards,

April 22, 2019 at 8:09 am #3654379

hlaingM

Hi, where is that place to check this specific box "duplicate"?

I saw the 2nd image in the section 2 (Select translation options) of the translation dashboard under the translation management. It looks different from the 1st image. Or is it what you are referring? If I click that "duplicate" in that place in the 2nd image, I won't be able to translate? right?

April 22, 2019 at 1:30 pm #3656013

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The first image if you are using 'WPML translation management'

The second image is when you edit the page directly : hidden link you will get here if you check the 'languages' meta box : hidden link

Let me know how it goes.

Regards,

April 22, 2019 at 4:17 pm #3656941

hlaingM

Are you saying that I need to set "duplicate" in all the pages so that when I click the flag of the secondary language on the FRONT PAGE, I won't get an error message???

April 22, 2019 at 4:37 pm #3657069

hlaingM

I am awaiting the answer for the question above....I have another related question.
I cannot select "duplicate" for some pages and I do not even see the place where "duplicate" is for some pages.

April 23, 2019 at 5:13 am #3659639

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You just need the WPML Translation Management plugin.

Try the following steps:
❌ Before proceeding please make a full website backup! ❌

- Go to WPML -> Translation Management -> Translation Dashboard (tab)
- Select "English" in the "Show documents in" drop-down.
- Increase the "Number of documents:"
- Select "Page" in the "Type:" filter drop-down
- Press the "Display" button

You should now see all the English translated pages.

- Select all the pages using the first checkbox
- Scroll down to the translation options section
- Choose the desired action for EACH language (eg. "Do nothing" for German, "Duplicate content" for Polish). Set "Do nothing" for any language that you don't want to duplicate.
- Press the "Duplicate" button. If the button is named differently, please verify that no language is set to "Translate".

I cannot select "duplicate" for some pages and I do not even see the place where "duplicate" is for some pages.
-
setting your settings to "falling back to the original" hidden link and selecting the checkbox to create a "duplicate" produces the same result, therefore the checkbox is removed once "falling back to the default language is selected"... there is no need for it anymore.

Please let me know if this solves the issue or if you need further details.

Thank you,

April 23, 2019 at 6:40 pm #3666957

hlaingM

Hi,

I saw that my WPML Translation Management plugin was activated. I got stuck at this point. I do not see what you said below.

- Select "English" in the "Show documents in" drop-down.
- Increase the "Number of documents:"

Thank you.

April 24, 2019 at 5:51 am #3669409

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry, actually i meant this hidden link and this hidden link

Hope, that will help you.

Regards,

April 24, 2019 at 7:24 pm #3676303

hlaingM

Hi, I just chose duplicate following your instructions. (1) With that, are you saying that I no longer need to check duplicate option (there is no duplicate option) on the Page-Edit anymore? (attached)

(2) On the Front Page, I already did the translation for "Message Box". Why isn't the translation not being displayed?

Please give me elaborate answers if possible. It is taking a long time for me just to get an answer for one small issue with our messages bouncing back and forth. Thank you.

April 25, 2019 at 7:08 am #3679337

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

1) Probably, on that page is not being duplicated via language meta box on page because the translation has already started.
Try to create a new page and check .

2) please create a new dedicated ticket for this to avoid the confusion and to reduce the waiting time.

Regards,

April 25, 2019 at 8:17 am #3679999

hlaingM

Hi,

"Try to create a new page and check"
-how can I create a new page?

Thanks,

April 25, 2019 at 1:44 pm #3682917

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

-how can I create a new page?
- just create a from WP dashboard > Pages > add new : hidden link and try to duplicate?
- are you seeing the same issue?

We started this ticket to show your Language Switcher in your site which has been fixed already and now we are discussing about duplicating pages with more replies than the replies that we created for the actual issue.
So this thread may confuse others issues.
If you can please open a new ticket for duplicating issue and close this.

Let me know how it goes.

Regards,