Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Robert 5 years, 5 months ago.

Assigned support staff: Maciej.

Author Posts
February 12, 2015 at 7:14 am #559365

Robert

Hi,
It's about chinasurfreport.com/en the Chinese flag href adds /home tot the URL. This results in a false Google search result as you can see in the Google topic link below.

I'm using the widget language switcher with SmartMag theme.

- In WP>settings>reading it has the homepage as default homepage.
- in WP>Pages>homepage slug is set as "home" right now thats why the flag adds the slug "home". Removing this slug creates a slug called 14-2. Not sure what that number is based on...

Topics I've created about this problem:
Same problem with different Theme. Maciej said it was a Theme compatability issue. https://wpml.org/forums/topic/language-switcher-adds-url-home-to-homepage
Google support: hidden link

Since I have the same problem with several websites using different themes I'd like to know how to correct the flag href tag.

Thanks!

February 12, 2015 at 10:03 am #559485

Maciej

Thank you for reporting this issue.

Can you please update your WPML plugins to the latest versions?
You can download them from the download section of your WPML account:
https://wpml.org/account/downloads/

Please let me know if this solves your problem.

February 13, 2015 at 5:32 am #560139

Robert

I've updated to wp 4.1 and updated all the wpml plugins. Still has the /home on the flag href.

Appreciate your help!

February 13, 2015 at 10:51 am #560299

Maciej

Thank you for your reply.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I would also recommend to backup your database and website first before we proceed. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

February 15, 2015 at 3:12 pm #560973

Robert

Hi Maciej,

I'm pleased and surprised to see suddenly the issue has been resolved. I checked, after updating, the WPML plugins, problem was still there - few days later I check again - the /home tag just disappeared.

So all good! (for now!)

Thanks

February 22, 2015 at 7:45 am #564470

Robert

Hi,
I would like to re-open this ticket. For some reason it shows adds the /home again on the website homepage. It was resolved earlier, so I'm curious what made it come back again 🙂

I've created a replica of the domain. How can I send you the login credentials of wp-admin and ftp?

Thanks

March 31, 2015 at 3:32 pm #591536

Robert

solution: https://wpml.org/errata/language-switcher-adds-front-page-slug-to-the-homepage-url/