This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by jeremyV-5 4 years, 11 months ago.

Assigned support staff: Bruno.

Author Posts
October 29, 2014 at 6:29 pm #502140

Marzia

I have to languages: english and russian. I choose to display the language switcher as a flag in one widget area (topbar right) but it is displaying twice, the first one is working, the second one at the botton is not working. If I try changing position in the topbar left, the flag is displayed correctly and it is working, but the not-working flag in the topbar right is stil there. What's going on? Many thanks

October 29, 2014 at 10:37 pm #502246

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'll ask for some information so I can verify the problem. The fields for you to insert the credentials will be below its comment field.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Thank you.

November 3, 2014 at 11:54 pm #504954

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I fixed your site. Please, could you check if this is working as intended?

Two flags were being displayed because you added the flag in the menu and then added a "Language Selector" widget.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

November 4, 2014 at 10:03 am #505149

Marzia

Thank you bruno, I don't get it ..there is a menu location up there? because i don't understand which location is, and anyway in wpml > Languages >Language switcher Options no menu is set, and in the widget area you deleted the widget. Can you explain where you set up the switcher? Many thanks.
I have another problem, and since you have credentials i post it directly here (or if you prefer I would open a new ticket): i cannot translate a post type (it says invalid post type). It is in Slider >Parallax Homepage Slider > View Slides (do that using English screen). In translation management Slider is already set to be translatable, but not its children slides. Thank you again.

November 4, 2014 at 10:36 am #505190

Marzia

sorry, I'll be more clear. Now the selector is displaying correctly, but I don't know how you did it. Thanks

November 4, 2014 at 1:42 pm #505391

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. I just removed the widget and kept the other flag that was on your site.

As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.

November 4, 2014 at 7:05 pm #505623

Marzia

ok, still cannot figure out why it is appearing there. Fortunately is in the place I want it otherwise I would not know how to remove it. Anyway, Thank you for your help.
I will open a new ticket fot the second question.

July 2, 2019 at 4:46 pm #4128893

jeremyV-5

language switcher appearing twice. How can I resolve this problem?