We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
As you can see in the attachment the background of the language switcher is too big.
Is it possible to make it as small as the flags?

Solution:
I have added following CSS in WPML >> Languages > Additional CSS section:
https://cdn.wpml.org/wp-content/uploads/2018/05/2237496-switcher1.jpg?x30111

.wpml-ls-item .sub-nav {  
  min-width: auto;
padding: 7px 0 0 0;
margin: 0;
}

This topic contains 7 replies, has 2 voices.

Last updated by giuseppeP-25 1 year, 5 months ago.

Assigned support staff: Noman.

Author Posts
May 28, 2018 at 9:57 am #2237496

giuseppeP-25

Hello,
as you can see in the attachment the background of the language switcher is too big.
Is it possibile to make it as small as the flags ?

Thank you

May 29, 2018 at 9:46 am #2244248

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

Thank you for contacting WPML Support. We can fix this issue by using some custom CSS code. Can you please share page url where I can see the issue and provide you required CSS.

Thank you

May 29, 2018 at 9:49 am #2244253

giuseppeP-25

Hello, the website is hidden link but now the English version is hidden. Do you need admin access?

May 29, 2018 at 10:38 am #2244822

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I can not see the dropdown in language switcher at the moment, For further debug this issue, please provide temporary access (WP-Admin Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 29, 2018 at 12:36 pm #2245821

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I have enable english language for a while and added following CSS in WPML >> Languages > Additional CSS section:

.wpml-ls-item .sub-nav {  
  min-width: auto;
    padding-right: 0;
    padding-left: 0;
    margin-left: 0;
}

And now it looks as in attached screenshot. Can you please check and confirm?

Thank you

May 29, 2018 at 12:48 pm #2245837

giuseppeP-25

Hello, it looks much better, thank you. Would it be possibile in your opinion to reduce a bit the white space at the top and bottom of the english flag (in your image)?
Thank you!!

May 30, 2018 at 7:23 am #2249205

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have updated following CSS in WPML >> Languages > Additional CSS section:

.wpml-ls-item .sub-nav {  
  min-width: auto;
padding: 7px 0 0 0;
margin: 0;
}

And now it looks as in attached screenshot. If you need to increase/decrease top and bottom spacing you can update padding values. At the moment, top padding is 7px and right, bottom, left are 0px respectively.

Can you please check and confirm?

Thank you

May 30, 2018 at 9:13 am #2249857

giuseppeP-25

Fantastic assistance, thank you