Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Language Switcher is not appearing in the header.

Solution: Log into your admin and navigate to WPML -> Languages -> Language Switcher options, scroll down and click Restore Default. Then reset your settings as desired, and click Save.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by jonathanF-3 5 years, 8 months ago.

Assigned support staff: Lauren.

Author Posts
November 20, 2015 at 8:37 pm #751681

jonathanF-3

Did the upgrade of WPML from a older version, but lost the language switcher in the header.

URL is private ( I can send it by email )

Before the update the language switcher was in the top header beside the social media icons, but now it just disapeared. Please confirm where I can send the link so you can look at it.

Thanks !

November 20, 2015 at 10:13 pm #751719

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi JonathanF-3, I'll be happy to help you with this. I have marked your next reply as private so that only you and I will be able to see the content, so you can safely post the URL in your next reply and I can troubleshoot the issue from there.

Thanks!

November 20, 2015 at 10:19 pm #751723

jonathanF-3

sorry the adress should end as ".com"

November 21, 2015 at 5:08 pm #751899

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for the info, Jonathan.

Please log into your WordPress Admin and navigate to WPML > Languages > Language Switcher Options. Check the box for either "Flag", “Native Language Name” or “Language name in display Language” (or all, depending on how you would like it displayed) . Then click Save.

If the issue persists, go to WPML > Support > Troubleshooting and click on "Clear the cache in WPML"

Please let me know if this resolves the issue.

November 22, 2015 at 9:15 pm #752114

jonathanF-3

The "Language name in display language" was already selected. If you look at the site, you will see that the language switcher is there, I am able to click it & get the proper language. The only problem is the visibility of it.... it's transparent. I've tried to use chrome inspector to find the proper class to add a color: black; property, but can't find it !

November 23, 2015 at 1:28 pm #752609

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Jonathan,

I need to request temporary access (WP-Admin and FTP) to your site – preferably to a test site where the problem has been replicated if possible – in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Thanks you.

November 24, 2015 at 1:25 pm #753595

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Jonathan,

The credentials you provided are no longer working for me - can you test and perhaps resend so that I can continue to troubleshoot the issue? I have marked your next reply as private which means only you and I can see and have access to it.

Thank you.

November 24, 2015 at 9:44 pm #754114

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Jonathan,

Please try logging into your admin and navigation to WPML > Languages > Language Switcher options and scroll down and click Restore Default. Then reset your settings as desired, and click Save. Please let me know if that resolves the issue.

Unfortunately that login is still not working for me. Can you please test and perhaps resend so that I can continue to troubleshoot the issue? I have marked your next reply as private which means only you and I can see and have access to it.

Thank you, I look forward to your reply.

November 25, 2015 at 4:40 am #754198

jonathanF-3

Now working ! Thanks