This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 4 voices.

Last updated by solonH 3 years, 4 months ago.

Assigned support staff: Bernat Torras.

Author Posts
February 1, 2017 at 10:00 pm #1196783

solonH

I am trying to: I updated to WP 4.71 and my language switcher disappeared. I also updated any pluggins that releases an update recently.

URL of (my) website where problem appears: hidden link

I expected to see:

Instead, I got:

Steps to duplicate the issue:

February 2, 2017 at 1:30 am #1196846

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for contacting WPML Support,

Please go to WPML->Languages and verify that your language switcher is assigned to the correct menu. (please share screenshot of settings if possible)

If you add a footer switcher does it function as expected?

February 2, 2017 at 6:40 pm #1197918

solonH

Hi Bobby,

I went to WPML->Languages and managed to add it. However, it looks very bad:
hidden link

It used to be on the right of "Cart". How do I make it to go there again?

Thanks.

February 2, 2017 at 8:11 pm #1198023

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for contacting WPML Support,

Which menu or location did you assign it to ?

Usually you have menus and specific locations depending on your theme.

If you would like to add it at a custom location please review the following documentation
=>https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#custom-locations

February 2, 2017 at 8:39 pm #1198046

solonH

Hi Bobby,

Please assign this to Bernat as I originally requested. We have worked together on this before and he is aware of my theme and specific issue.

Thanks,
Solon

February 3, 2017 at 4:56 pm #1199066

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Solon, Bobby is off today but I have assigned this to Bernat as requested. He will follow up with you shortly.

February 6, 2017 at 12:34 pm #1200287

Bernat Torras

Hi @solonh,

Sorry, I was off these days and I wasn't able to catch your ticket on time!

I've checked your backend and I see that you've added your language switcher in WPML>Languages>"Widget language switcher" area. Could you disable it and add it as a "Menu language switcher"? Make sure to select your secondary menu in the menu selector that will appear in the language switcher customization popup.

Could you try it and confirm us if you display it in the desired location?

Thanks,
Bernat

February 7, 2017 at 9:11 pm #1202286

solonH

Thank you Bernat, that worked!