This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 8, 2018 at 6:59 pm

yuliaK-2

I am trying to: fix the issue

Link to a page where the issue can be seen: boonia.com on mobile

I expected to see: language switcher in mobile menu

Instead, I got: Every time i edit ANY widget, (not switcher) my language switcher disappears from mobile menu, so I have to re-add every time.

October 9, 2018 at 9:12 pm #2802162

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

The topic ‘[Closed] Language switcher disappears from mobile menu after any other widgets edit’ is closed to new replies.