This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 1 year, 1 month ago.

Assigned support staff: Noman.

Author Posts
September 15, 2018 at 7:50 am #2737356

peterO-17

I have added the language switcher to the menu. I have worked with WPML before on different websites. Unfortunately the language switcher does not show the arror indicating you can choose another language.

In the WPML menu itself it does show the arro below the header "Menu language switcher".

Please see attached screenshot.

I would like to see the arrow for the options.

Thank you for yourhelp.

September 16, 2018 at 2:52 pm #2738976

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can add arrow by adding following CSS in your theme’s or child theme style.css file OR Custom CSS section of the theme:

.wpml-ls-item.menu-item-has-children::after {
    content: '\f107';
    font-family: FontAwesome;
    position: absolute;
    top: 11px;
    right: 145px;
}

Please try it and let me know how it goes. Thank you

September 18, 2018 at 9:04 am #2744132

peterO-17

Hi,

Thanks for your help. Almost there I guess, but I do not see the icon 🙂 only two vertical lines:

hidden link

Regards,

Richard

September 18, 2018 at 11:51 am #2744881

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please try with the following CSS:

.wpml-ls-item.menu-item-has-children::after {
    content: '\f105';
    font-family:icomoon!important;
    position: absolute;
    top: 10px;
    right: 145px;
}

And it will look as in attached screenshot.

Thank you

September 18, 2018 at 3:59 pm #2745791

peterO-17

Hi,

Thanks, but the arrow only appears from English (default) to Dutch. When the language is switched to Dutch, the arrow does not appear.

Regards,

September 19, 2018 at 7:16 am #2747535

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Arrow is appearing behind Dutch language text as text is bigger than english text. We need to change arrow margin from right side. Please replace following CSS:

.wpml-ls-item.menu-item-has-children::after {
    content: '\f105';
    font-family:icomoon!important;
    position: absolute;
    top: 10px;
    right: 145px;
}

with:

.wpml-ls-item.menu-item-has-children::after {
    content: '\f105';
    font-family:icomoon!important;
    position: absolute;
    top: 10px;
    right: 15px;
}

It will fix this issue.

Thank you

September 19, 2018 at 12:29 pm #2748705

peterO-17

Hi,

Thanks for the help. Unfortunately it looks like the arrow issue only is an issue on PC screen. On mobile I now see 2 arrows 🙂

I also asked Theme-fusion, creator of Avada to take a look at this. Maybe it is something in the theme.

Regards,

September 19, 2018 at 1:10 pm #2748858

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can target just desktop screens by using following CSS:

@media only screen and (min-width: 1100px) {
/* For desktop: */
.wpml-ls-item.menu-item-has-children::after {
content: '\f105';
font-family:icomoon!important;
position: absolute;
top: 10px;
right: 15px;
}
}

Thank you

The topic ‘[Closed] Language switcher does not show arrow for other option(s)’ is closed to new replies.