This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.77 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 3 voices.

Last updated by timK-30 1 year ago.

Assigned support staff: Andrés.

Author Posts
October 9, 2018 at 2:03 pm #2800342

timK-30

Hi,
I've inserted the language-switcher via elementor on my site-header.

[wpml_language_selector_widget]

its working fine on all pages except the home page.

Thank you

October 10, 2018 at 9:11 am #2803584

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please make sure you have translated all elements that are showing on homepage.

Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

October 10, 2018 at 1:57 pm #2804595

timK-30

Thanx Noman,
the page ist completely translated. Please find the debugreport above.

October 10, 2018 at 3:00 pm #2804910

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

- Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest official release version. Or you can download it from your account: https://wpml.org/account/downloads/

- Please clear all sort of caches in your site plugin cache (WP Fastest Cache) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and Elementor and see if this issue goes away with default theme and only WPML activated?

Please let me know how it goes?

Thank you

October 11, 2018 at 10:32 am #2807648

timK-30

Hi Noman,
I've tried these steps, but unfortunately it still doesn't work. If I disable elementor the switcher disappears on all pages (I think because I've inserted it via elementor).
Do you have another idea?
Thank you

October 11, 2018 at 11:16 am #2807752

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 15, 2018 at 2:20 pm #2817938

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Tim,

As Noman is not available I would like to take care of your case.

I have tried to replicate your issue but I don't know which is your Elementor template or how to reproduce the issue.

Could you please provide me more details about how to reproduce this issue?

Regards,
Andrés

October 16, 2018 at 11:08 am #2820686

timK-30

Hi Andrés,
The language switcher is not shown on the Startpage (Home), due to it is inserted in the whole siteheader. The Template is a child of Specia. The switcher is inserted with elementor via shortcode [wpml_language_selector_widget], you'll find it there (Elementor > my templates > header). The switcher should also be shown on the homepage.
regards, Tim

October 16, 2018 at 11:50 am #2820810

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you for your explanation, Tim.

It seems that your theme or any other element on your site is adding the following CSS that is blocking your Language Switcher:

.elementor-shortcode {
    display: none;
}

For solving it, I went to WPML > Languages > Language switcher options > Additional CSS (optional) and added the following CSS:

.elementor-shortcode {
    display: block !important;
}

Does it help?

Regards

October 16, 2018 at 12:24 pm #2820914

timK-30

My issue is resolved now. Thank you!