This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by lauriL-5 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 14, 2019 at 4:31 pm #4396631

lauriL-5

Hi,

After moving my site from subdomain (hidden link) to root domain (hidden link) my language switcher does not work anymore.

Best regards,
Lauri

August 14, 2019 at 7:04 pm #4397135

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 15, 2019 at 2:42 pm #4401793

lauriL-5

Hi Marcos,

Have you had a time to check the issue?

Best regards,
Lauri

August 15, 2019 at 3:05 pm #4401871

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Lauri,

Thank you for the updates. I tried to access your FTP using the provided details but it doesn't seem to be correct. I need to review your .htaccess and wp-config.php files in order to find the cause of the issue, this is why the correct FTP access details are needed. Can you review it please? A private reply is now enabled for you, so you can safely resend these details. Thank you for your collaboration and patience, have a nice day.

August 15, 2019 at 3:17 pm #4401885

lauriL-5

Hi,

My mistake, correct details are attached.

Best regards,
Lauri

August 15, 2019 at 6:29 pm #4403033

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

August 15, 2019 at 7:15 pm #4403159

lauriL-5

Hi,

The migration is done.

Best regards,
Lauri

August 16, 2019 at 6:17 am #4404831

lauriL-5

Hi Marcos,

Could you please check the issue as soon as possible, because I would like to open the new website asap.

Best regards,
Lauri

August 16, 2019 at 2:30 pm #4406941

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Lauri,

Thank you for the updates and sorry for the bit of waiting here. I took a look at your website using the migrated copy and noticed the language swticher works properly without any manual intervention, it means you might have some wrong values for your database site url and home url fields in your _options table and it happened when you changed your domains. Please check the following resources in order to lean on how to check it:

1 - Updating the site url in the database: https://wordpress.org/support/article/changing-the-site-url/#changing-the-url-directly-in-the-database

2 - Instructions to properly move your website: https://wordpress.org/support/article/moving-wordpress/

You can confirm it works properly when a correct url is set in the database site url and home url fields at: hidden link

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if you need any additional assistance and clarifications. Have a nice day.

August 17, 2019 at 8:37 am #4409613

lauriL-5

Hi,

Thanks for the info, I will check the resources you sent.

Best regards,
Lauri

August 19, 2019 at 6:42 pm #4418359

lauriL-5

Hi,

I found a notification on the wpml - languages - Language URL format. I attached a image ot that. How can I fix this issue?

Best regards,
Lauri

August 19, 2019 at 9:39 pm #4419299

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Lauri,

Thank you for the updates. In most causes these are the cause of this issue:

1 - Your permalink structure is not set as 'post name' in your WordPress Dashboard > Settings > Permalinks.

2 - Your WordPress installation files is not in the root directory of your host public folder.

3 - You may have wrong settings in your .htaccess or it doesn't have write permissions.

4 - In some cases the issue could be a false positive if your website actually works with the language in directories option.

I tried to access your website to give a detailed look into this issue but the provided access credentials don't seem to be working anymore.

Please, let me know if it helps, have a nice day.

See: https://wpml.org/faq/server-setting-for-languages-in-directories/

August 20, 2019 at 6:02 am #4420659

lauriL-5

Hi,

My permalink structure is set to post name, WordPress installation is in root directory. Could you please take look at my site, now the credentials should work.

Best regards,
Lauri

August 20, 2019 at 6:56 am #4420935

lauriL-5

Hi,

I just found out that my site is going to be copied today again from the subdomain to root. I will let you know when that is done, so you can take a look at the issue.

Best regards,
Lauri

August 20, 2019 at 2:53 pm #4424679

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Lauri,

Thank you for the updates. Please, let me know once you are ready, have a nice day.