This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Noman 8 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
September 6, 2019 at 6:06 pm


I am trying to: add the english translation to the site

Link to a page where the issue can be seen: hidden link

I expected to see: to see the language switcher when the english language is selected but it shows a facebook and email icon. It seems the page is cached, I had the problem before when i added the spanish language but could resolve it for the spanish langiage. Just don´t remeber what i did.

Instead, I got: the facebook and email icons. In the theme settings of Avada I selected the topmenu at this position in stead of the icons.

September 8, 2019 at 9:46 am #4531085


Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting WPML Support. It seems you have different theme options in English language and that's why you are facing this issue.

In Avada theme you can translate theme options by switching different language using the Language Switcher in the top of the WP Admin panel. If you want to apply the same styling/settings on all languages then after installing WPML please select ‘All Language’ options from wp admin language switcher then save theme options.

Once you've selected ‘All Languages’ option from the dropdown, the theme options for all the languages will be replaced by the default language you have set in WPML options. Once you make changes to any theme option, that change will be applied on all WPML languages.

Here is doc for more details:
hidden link

Thank you