This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Language Switcher doesn't appears only the main site

Solution: https://wpml.org/forums/topic/language-selector-not-showing-other-languages/#post-1304586

This topic contains 4 replies, has 2 voices.

Last updated by domonkosR 6 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 3, 2019 at 2:12 pm #3526993

domonkosR

I am trying to make a site on 3 languages. The main site is English and I see the language switcher. But on the other sites (German and Hungarian) the language switcher is not available.

How can I change the setup the language switcher on the additional sites ?

April 3, 2019 at 3:49 pm #3528355

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

As per your debug information I see you have selected this option: hidden link
So if you did not translate a page 100 percentage the language switchser wil not be shown.

Please translate your page hundred percentage to the other languages and check the issue.

Hope, that will help you.

Let me know how it goes.

Regards,
Riffaz.

April 4, 2019 at 9:24 am #3533541

domonkosR

Hi Riffaz,

thank you for your advice but the pages are 100% translated. So it doesn't help.

Do you have any other suggestion?

Thank you!

Best Regards,

Tímea

April 4, 2019 at 6:28 pm #3537725

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Could you please check these? https://wpml.org/forums/topic/language-selector-not-showing-other-languages/#post-1304586

And, how did you create this language switcher?

Regards,

April 5, 2019 at 7:37 am #3541551

domonkosR

My issue is resolved now. Thank you!