This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am trying to resize the language switcher but its not working.

Solution:
You can fix this site issue by adding below CSS in WPML >> Languages > Additional CSS section:

.wpml-ls-item ul {
    min-width: auto !important;
}

.wpml-ls-item ul li a {
    padding-right: 12px;
}

This topic contains 2 replies, has 2 voices.

Last updated by henryM-3 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
May 4, 2019 at 11:36 pm #3741027

henryM-3

I am trying to: I am trying to resize the language switcher and I have tried three pieced of code.

li.wpml-ls-menu-item ul li a {
width: auto;
}

.wpml-ls-item ul.sub-menu {
display: block !important;
width: 58px !important;
}

#access ul .wpml-ls-item ul {
width:auto;
}

and

.wpml-ls-item ul.dropdown-menu {
max-width: 58px !important;
min-width: auto !important;
}
.wpml-ls-menu-item .wpml-ls-flag {
min-width: 18px;
}

Link to a page where the issue can be seen: hidden link

I expected to see: I am a hoping to eliminate the extra space after the flags.

Instead, I got: nothing happens with either piece of code.

May 5, 2019 at 9:48 am #3742327

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can fix this site issue by adding below CSS:

.wpml-ls-item ul {
    min-width: auto !important;
}

.wpml-ls-item ul li a {
    padding-right: 12px;
}

in WPML >> Languages > Additional CSS section and it will look as in attached screenshot.

Thank you

May 7, 2019 at 1:49 pm #3758715

henryM-3

My issue is resolved now. Thank you!