This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by pierre-romualdS 2 months ago.

Assigned support staff: Bigul.

Author Posts
August 15, 2019 at 3:26 pm #4401953

pierre-romualdS

I am trying to: have all languages appear in the right top bar

Link to a page where the issue can be seen: hidden link

I expected to see: english, french, spanish & portuguese

Instead, I got: only English

August 15, 2019 at 5:36 pm #4402745

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you translated Homepage or other pages to secondary languages? Normally the language switcher will be only visible if we translate Posts or Pages.

Please visit Settings>>Reading and check you are getting any warning under *Your homepage displays* section or not.

Please create a Test Post and duplicate it to secondary languages. Then check you are getting the expected result or not.

--
Thanks!

Bigul

August 15, 2019 at 6:31 pm #4403037

pierre-romualdS

My issue is resolved now. Thank you Bigul!

I just visit the reading section and check the warning message under home page.