This thread is resolved. Here is a description of the problem and solution.

Problem: On mobile, when I open the dropdown it is not possible to close the dropdown by clikcing on the already chosen language or the arrow. Is it possible to config the behavior of the dropdown, so it close when I click on the arrow or the already chosen language?

Solution: I have fixed this issue by selecting ‘Dropdown Click’ option from Language switcher settings as you can see in attached screenshot and added following CSS: https://cdn.wpml.org/wp-content/uploads/2018/09/2774281-dropdown_click_option.png?x59034

@media(min-width:992px) { .wpml-ls-item-legacy-dropdown-click:hover ul{ visibility: visible !important; } }

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.20 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by sorenH-9 1 year, 9 months ago.

Assigned support staff: Noman.

Author Posts
September 28, 2018 at 2:16 pm #2774202

sorenH-9

Hi Norman,

That solved my issue! Thank you 🙂

One more thing...
On mobile, when I open the dropdown it is not possible to close the dropdown by clikcing on the already chosen language or the arrow.
I can only close it by clicking another place on the site or by choosing a different language.
Is it possible to config the behavior of the dropdown, so it close when I click on the arrow or the already chosen language? Hope you understand what I mean.

If you take a look on my attached image. Imagine it is on a mobile. I expect the dropdown to close, when I click inside the blue square. But unfortunately it doesn't (on mobile).

Best regards,
Søren

September 28, 2018 at 3:06 pm #2774281

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have fixed this issue by selecting ‘Dropdown Click’ option from Language switcher settings as you can see in attached screenshot and added following CSS:

@media(min-width:992px) {
.wpml-ls-item-legacy-dropdown-click:hover ul{
visibility: visible !important;
}
}

Now issue is gone. Could you please clear your site cache and take another look on it.

Thank you

September 28, 2018 at 6:37 pm #2774650

sorenH-9

You are the best! Thank you!