This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: language switcher "english | Français" links to switch on main menu doesn't work

Solution:Solution here : https://wpml.org/forums/topic/after-updating-to-3-6-1-the-language-flag-in-mainmenu-is-no-longer-clickable/

Relevant Documentation:

This topic contains 14 replies, has 2 voices.

Last updated by Fabrice Mafille 2 years, 8 months ago.

Assigned support staff: Bobby.

Author Posts
December 13, 2016 at 10:32 pm #1159449

Fabrice Mafille

Since 3.6 WPML Multilingual CMS update

I am trying to: switch between languages with language switcher on my main menu

URL of (my) website where problem appears: hidden link
Wordpress theme : hidden link

I expected to see for example :

page hidden link when I'm on page hidden link and click English for

page hidden link when I'm on page hidden link and click Français

Instead, I got: Nothing, the links doesn't work !

My theme provide this wpml-config.xml :


<wpml-config>
  <language-switcher-settings>
        <key name="display_ls_in_menu">1</key>
        <key name="icl_lang_sel_type">classic</key>
        <key name="icl_lso_flags">1</key>
        <key name="icl_lso_native_lang">1</key>
        <key name="icl_lso_display_lang">1</key>
  </language-switcher-settings>
</wpml-config>

is it the problem !?

Note that if i configure a language switcher in the footer it's work

Steps to duplicate the issue: go to the website hidden link and after the welcome page where you can choose your native language try to switch to another

Note that i put a custom link (first at right of the contact button) to switch without the wpml switcher for the moment.

thanks by advance !

Fabrice

December 13, 2016 at 11:07 pm #1159472

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi,

The theme provided .xml file shouldnt be the issue this is there for translations purposes.

At this moment when i go to the site it works but you mentioned that you are using a custom link ?

How is this custom link configured?

When you have the WPML lang switcher activated what is the URL that its directing you to?

December 13, 2016 at 11:29 pm #1159477

Fabrice Mafille

Hi Bobby

The custom language link near my contact link is from wordpress menu :

Appearance / Menu /

here is a screenshot of the my english page menu with detail of the custom link setting

after at the right side, the wpml language switcher is integrated perfectly on my main menu but not work

December 14, 2016 at 12:04 am #1159485

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi,

Thank you for the screenshot , would you mind if i took a look trying to use the WPML language switcher

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

December 14, 2016 at 8:59 pm #1160558

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi.

May i kindly ask you to please verify the FTP details they are currently not allowing me to access your FTP

December 15, 2016 at 12:03 am #1160645

Fabrice Mafille

Sorry for that, now it's will be ok, you can access !

December 15, 2016 at 12:12 am #1160647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi,

The public_html root folder does not exist in the FTP and also im receiving a 404 on the site.

December 15, 2016 at 12:17 am #1160648

Fabrice Mafille

I fix the issue quickly and come back to you soon !

December 15, 2016 at 1:09 am #1160665

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please update me once up and working so i will be notified

Thank you,
Bobby

December 15, 2016 at 4:58 pm #1161434

Fabrice Mafille

Hi Bobby,

Sorry for the delay, I have create the wordpress and ftp access for you, everything work fine now, you're able to access to the folder to look for a solution 🙂

Thanks by advance !

December 15, 2016 at 9:43 pm #1161671

Fabrice Mafille

Hi Bobby,

I've just seen this threads :

https://wpml.org/forums/topic/after-updating-to-3-6-1-the-language-flag-in-mainmenu-is-no-longer-clickable/

It's look that the case is in the hands of the Brooklyn theme developer (I had post a thread about the problem in the Brooklyn support too) and your team to help.

🙂

December 15, 2016 at 10:04 pm #1161681

Fabrice Mafille

Thank you for your help, I think that the solution will be find quickly now 🙂

December 16, 2016 at 5:07 am #1161795

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Fabrice,

we do have a few reports regarding this issue with the Brooklyn theme and we are currently contacting the Author.

Were you able to perform the work around and it did not work ?

December 16, 2016 at 1:51 pm #1162291

Fabrice Mafille

Hi Bobby,

Sumit have add one new line to change in the .php file and the solution work !

Thank you very much for your help !!!

🙂

Solution here : https://wpml.org/forums/topic/after-updating-to-3-6-1-the-language-flag-in-mainmenu-is-no-longer-clickable/