This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Siham Benmohad 2 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 11, 2019 at 6:44 pm #4192697

Siham Benmohad

I am trying to: Make my main menus correspond with the language selected. worked well until 2 days ago.

Link to a page where the issue can be seen: 4woods.eu

I expected to see:when clicking on English flag, main menu is supposed to be in english. Problem on menu only, for the content of the page is in english.

Instead, I got: when I am on french language & click on english flag, menu still remains in french. English speaking visitors are sent to french pages when clicking on this menu, even if the homepage is in english.

Can someone help me ?

July 11, 2019 at 10:29 pm #4193359

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. When I access your site in English the menu appears to be displayed correctly. I'll attach an image for you to see.

Have you tried to access your site from another browser or clear your browser's cache for testing?

Thank you.

July 11, 2019 at 10:35 pm #4193383

Siham Benmohad

Hi Bruno,

It is weird, my issue is real. I've received a few emails from visitors about this, even one this evening again. I have cleared my cache, and tried with Firefox, Chrome and Safari, there is a problem. Can you see again please ?

July 12, 2019 at 10:01 am #4197333

Siham Benmohad

Hi Bruno,

Have you had the time to see ? I promise my issue is real, I still have it now. I don't know where to ask for help, I've been in the WPML settings, I've been in my menus settings.

Please help me.

Regards,
Siham

July 12, 2019 at 6:39 pm #4201125

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Siham,

Sorry for the delay. Yes, I can now see the problem you are reporting. This seems to be a cache issue. Please could you clear and disable the cache (both the cache plugin and any cache you have on your server) so that we can test better?

Thank you.

July 14, 2019 at 7:40 pm #4205933

Siham Benmohad

Hi Bruno,
Sorry for the delay.
I have disabled the cache (W3 total cache), and it seems to work correctly without it.
How can I fix the issue now ?
Thank you,

July 15, 2019 at 7:36 pm #4214383

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

After you disable the cache and re-enable the problem still persists?

If yes, you will need to test with all non-WPML plugins disabled, including and caching and then enable caching to test. That is, in the end only the WPML plugins together with the cache will be enabled to see the behavior of the site menu.

By default, the cache should cache the current page - that is, in English generate the page cache in English and in French, generate the page cache in French.

This may be related to some cache configuration or some other plugin that may be causing this compatibility problem.

Thank you.

July 22, 2019 at 8:16 am #4254775

Siham Benmohad

My issue is resolved now. I've removed W3 Total Cache, and replaced it with an other one.