This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 5 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 15, 2019 at 10:21 am

antonioO-9

I am trying to: publish my italian website also in english

Link to a page where the issue can be seen: hidden link

I expected to see: Italian menu in italian version and english menu in english version. Also the languange switcher that not link on an internal page.

Instead, I got: always english menu and language switcher go to an internal page.

May 15, 2019 at 4:57 pm #3818967

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, whenever I disable all the other plugins and leave only the WPML plugins active, the menu works in both languages.

Please follow the next steps:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Let me know how that goes.

Kind regards,
Mihai Apetrei