This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.58 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 6 months ago.

Assigned support staff: Andreas W..

Author Posts
April 15, 2019 at 9:36 pm #3616597

shamisA

I am trying to:
although its working in other page
Link to a page where the issue can be seen:
hidden link
I expected to see: its working her for Ex:
hidden link

April 15, 2019 at 10:17 pm #3616657

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Go to WPML -> Languages -> Site URL structure and choose Language in directories. Then got to Settings -> Permalinks and click the save option. Please also make sure to choose a permalinks settings that is not too simple (as plain or name).

Now, please make sure that the page that you would like to call with the language switcher is completely translated, otherwise it will not show up.

Follow these tasks and let me know if the language switcher now is working as expected.

Kind regards
Andreas

April 16, 2019 at 10:14 am #3620901

shamisA

thats what happened

April 16, 2019 at 3:42 pm #3623641

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

You should be able to solve this issue by setting up a root page. More information about that topic you will find here:
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Let me know if this solved the issue.

Kind regards
Andreas

April 17, 2019 at 11:52 am #3630297

shamisA

i created a root page after your last suggestion but the links are automatically changing
to hidden link the must stay swedarab.se/en...

April 17, 2019 at 5:12 pm #3633369

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please verify your htaccess file? It should look like this:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /en/yourfolder
RewriteRule ^yourfile.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /en/yourfolder/yourfile.php [L]
</IfModule>

More information here:
https://wpml.org/faq/server-setting-for-languages-in-directories/

Let me know if this solved the issue.

Kind regards
Andreas

April 17, 2019 at 5:15 pm #3633371

shamisA

it looks exactly like the following:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

April 17, 2019 at 5:57 pm #3634149

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 17, 2019 at 10:49 pm #3634983

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I have taken a look at your page, which I tested in a minimal environment and also run wp-debug. I was not able to point out any issue in regards to a installed plugin or theme.
https://wpml.org/documentation/support/debugging-wpml/

Could you please connect to your server administration and check for the server error.log as this might give us more detailed information about the issue.

It appears to me that in your particular case the the issue is caused by a false server configuration. Please contact your host for assistance if needed.

I will be out of office from Thursday to Monday. If urgently needed please make sure to open a new ticket in the meantime. Otherwise, I will be returning on Monday to assist you.

Kind regards
Andreas

The topic ‘[Closed] language switcher in home page isn't working’ is closed to new replies.