This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.26 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 3 voices.

Last updated by Carlos Rojas 1 year, 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 28, 2018 at 11:53 am #1875388

Albin

I am trying to: click on flag icon and change language

Link to a page where the issue can be seen:www.selinasevil.se

I expected to see:another language

Instead, I got:not clickable

April 29, 2018 at 4:38 pm #1884729

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

While one of my teammates takes care of your case I will provide you with the first debugging steps.

Your theme is adding some extra CSS rules that creates this behaviour. Could you please go to WPML > Languages > Language switcher options > Additional CSS (optional) and add the following CSS:

#header-switcher {
    z-index: 9999;
}

Documentation:
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Let us know if it helps.
Andrés

May 3, 2018 at 7:23 am #1948654

Albin

Hi
I added the code, but my page don't show the flags at all in the menu.

May 3, 2018 at 7:32 pm #1965531

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
My name is Carlos and I will be taking this ticket.

I have visited your site and it seems that the flags in the menu are working correctly (see attached images). If the issue persists, would you mind to elaborate more about it? This way I can have a better understand.

Note: I recommend you to visit the site in incognito mode, this way you won't have any issues related to cache memory.

Kind regards,
Carlos

May 4, 2018 at 5:01 pm #1979288

Albin

Hi where are the attached images?
Im talking about the flags that are suppose to be next to the hamburger menu. They are not there at all anymore. What is incognito mode?
Thanks

May 4, 2018 at 6:01 pm #1979882

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm sorry it seems I forgot to attach the images.

In the attached images you will see the flag icons I tested. If this aren't the flags with the issue I kindly ask you to attach an image in your next message and show me the place where the issue is happening.

Kind regards,
Carlos

May 4, 2018 at 6:11 pm #1979930

Albin

Thats not the icons I'm referring to. They should show next to the hamburger menu

May 4, 2018 at 6:49 pm #1980181

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

The topic ‘[Closed] Language switcher in menu don't work’ is closed to new replies.