Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Dennis 1 year, 4 months ago.

Assigned support staff: Dennis.

Author Posts
May 19, 2019 at 2:50 pm #3841915

jeroenv-42

On the homepage of my website, the language switcher is not displaying the translated version of this page. On all other pages, the language switcher works fine, but on the homepage, the Dutch translation in the language switcher redirects to the English version.

May 20, 2019 at 7:36 am #3844251

Dennis

Hi,

Welcome to WPML Support forum.

Have you tried running routines from WPML troubleshooting page? If not, could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Does it help? Please let me know.

Kind regards,
Dennis

May 22, 2019 at 9:46 am #3863913

jeroenv-42

No, that didn't solve the issue unfortunately.

May 22, 2019 at 10:05 am #3864107

Dennis

Hi,

Thank you for your updates.

Could you please do the following test?

-Take a complete backup of your site. (important!)
-Deactivate all non-WPML plugins, except the plugins required for your theme.
-Check if the issue persists.
-If the issue is solved. If yes, begin to activate one by one the plugins until you figured out what plugin was causing the issue.
-If the issue still persists, deactivate all non-WPML plugins and please try to switch the theme to one of WordPress default themes (e.g. twentysixteen)

Please let me know how it goes.

Kind regards,
Dennis

May 26, 2019 at 2:32 pm #3891809

jeroenv-42

Unfortunately, that didn't work as well.

May 27, 2019 at 3:11 am #3893211

Dennis

Hi,

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

The topic ‘[Closed] Language switcher in menu not showing page in other language’ is closed to new replies.