If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 11, 2019 at 12:30 pm #3995037

nicholasA-4

We have 2 custom post types on our site and we have kept those post types to be "Not translatable" on the settings page. Now when we are viewing those pages on frontend the URLs are working with different languages but the language switcher is not showing for that post type archive page compared to single pages.
Any idea why?

Regards,
Nick

June 11, 2019 at 1:31 pm #3995727

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

June 11, 2019 at 1:58 pm #3995833

nicholasA-4

Why do you need SFTP access right away? Have you taken a look at my site?

These are the URLs:
hidden link
hidden link

June 11, 2019 at 2:19 pm #3996037

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Yes, I took a look at your site but I don't have enough information about the issue to give you an answer, that's why I asked for temporal access to the site, to take a closer look at the configuration and try to find the cause of this behavior.

Please provide the debug information of the site.

Regards,
Carlos

July 7, 2019 at 9:12 pm #4158219

nicholasA-4

Hello, thanks for your patience. Can you enable the private message so I can send you the crednetials?

July 8, 2019 at 12:57 pm #4162641

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I have set your next answer private so you can provide access credentials in a secure way.

Regards,
Carlos

July 8, 2019 at 8:57 pm #4165789

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the credentials provided.

However I tried several times to log in the site but I couldn't. Could you provide a direct link to the regular WordPress login page?

Regards,
Carlos

July 9, 2019 at 6:09 am #4167581

nicholasA-4

So the site is password restricted.
First, you have to use the other credentials I have sent you.
Then you have to go to this page:
hidden link
There you enter the second credentials I have sent you.
Then please visit this page: hidden link

If a page is not loading immediately just reload it.

July 9, 2019 at 11:15 am #4170055

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

1.- This time I was able to log in the site. Before we continue I need to ask you to update all outdated plugins and themes. Outdated functionalities can cause conflicts in the code.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Could you tell me if the issue persists after the steps above?
Regards,
Carlos

July 11, 2019 at 9:23 pm #4193147

nicholasA-4

Hello Carlos,

I updated all plugins and themes on my development site except for 2 toolset plugin because it threw an "undefined" error when updating and I couldn't update one paid plugin because the license expired but I just deactivated that plugin for you:

I added a new development env. This is the URL: hidden link the login credentials are almost the same. I can add them in the next private message for you.

I also increased the memory limit for you

July 12, 2019 at 1:04 pm #4199125

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I have set your next message private, so you can provide the credentials of the new test site in a secure way.

Regards,
Carlos

July 12, 2019 at 1:29 pm #4199343

nicholasA-4

to enter the new testing site:

username: ***
psw: ***

hidden link
*** / ***0

admin: hidden link

FTP access details:
hidden link
*** / ***

July 12, 2019 at 2:08 pm #4199567

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the credentials.

Could you tell me where the custom post types where created?

Also, I would like to ask your authorization to run tests in the staging site.

Regards,
Carlos

July 12, 2019 at 3:03 pm #4200041

nicholasA-4

The custom post type was created with the youtube channel plugin. You'll find the code in that plugin.

You can also check out other custom post types such as hidden link which were created with the toolset types plugin. The problem also exists on these pages

And yes you can run several tests on this site hidden link

July 15, 2019 at 11:05 am #4210117

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your authorization.

Could you tell me how you added the menus? Specifically the one that has the language switcher?

As fas as I can see the site doesn't have menus, in Appearance -> Menus

Regards,
Carlos