This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 1 year ago.

Assigned support staff: Noman.

Author Posts
September 14, 2018 at 8:48 pm #2736671

raviS-4

I set a language switcher in this site.
But, it is not showing up in the menu.

hidden link

Plz rectify the issue.

September 17, 2018 at 8:56 am #2740315

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M');

- You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest official release version. Or you can download it from your account: https://wpml.org/account/downloads/

- I have noticed that you are using older version ( 2.9.5 ) of The SEO theme and latest version of The SEO theme is 2.9.9, please update the theme and let me know if this resolves the issue or not.
hidden link

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Here is doc:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Thank you

September 18, 2018 at 8:42 pm #2746493

raviS-4

Updated theme.
Updated wpml.
Increased memory limit.

Tried disabling other plugins without changing theme.
Result: The menu appeared. Though clicking on it doesn't open it.

Tried switching theme to twenty sixteen.
Result: Same.

September 19, 2018 at 11:08 am #2748535

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 23, 2018 at 8:16 pm #2758978

raviS-4

I got it checked by the theme creator.

He said:-

Hello!
I have deactivated "SuppaMenu Pro" plugin and activated "Twenty Fifteen" of WP, WPML doesn't show the menu language switcher hidden link . You should tell WPML developers about this because it looks like a bug. I need their HTML markup to add to "SuppaMenu Pro" plugin.
Best regards

September 24, 2018 at 1:07 pm #2760528

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I can see menu language switcher (English flag) in the screenshot that theme creator sent in earlier message.

I have also checked in my localhost with WPML and twentyfifteen theme. WPML language switcher showing correctly in main menu as you can see in attached screenshot.

So the issue is somewhat related to the your theme or "SuppaMenu Pro" plugin. This plugin is not listed in our Multilingual Ready Plugins compatibility list: https://wpml.org/documentation/plugins-compatibility/

At this point, I would suggest to contact the theme/plugin author and share the link to this thread, you can pass him all above info.

Also you can refer the plugin author to our Go-Global Program:
https://wpml.org/documentation/theme-compatibility/go-global-program/

If you are familiar with programming you can follow below doc in order to display custom language switcher in your site:
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Thank you

September 28, 2018 at 2:44 pm #2774261

raviS-4

Hi WPML team.
Can u suggest me another theme for this Digital Marketing and Web Development business-profile website :-
seowebdev.co

- Theme shud be compatible with WPML properly.
- Shud be high quality with similar or better design and presentation
- Shud be high speed delivering so that it loads fast and ranks good.
- Shud not have bugs as in present theme which is actually a 3rd class crap theme full of bugs & bugs everywhere.

Plz advise
Regards

September 28, 2018 at 3:37 pm #2774329

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I would recommend you to use Divi or Avada theme. You can see more details from here:
Divi: hidden link
Avada: hidden link

If you are interested in some other theme then you can make sure wpml compatibility by searching that theme name in our verified theme list:
https://wpml.org/documentation/theme-compatibility/

Thank you

The topic ‘[Closed] Language switcher is not displaying in the menu’ is closed to new replies.