This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
December 18, 2018 at 8:29 am #3011265

איילה הלוי

I am trying to:translate

Link to a page where the issue can be seen: hidden link

I expected to see:in main menu - a working Language Switcher bottum

Instead, I got:see attachment

December 18, 2018 at 8:37 am #3011292

איילה הלוי

Please unswer as fast as you can! your team Supporters are allways busy...And its very urgent to me to move forwarth

December 18, 2018 at 10:16 am #3011578

איילה הלוי

Anyone???

December 18, 2018 at 4:57 pm #3013197

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To display flag on the front-end, please make sure these two things are met:
a) Your developer should have added the language switcher to one of the site’s menus or as a widget.
b) The contents you are viewing on the front-end must be translated. You can translate one page yourself to see if the language switcher appears correctly.
https://wpml.org/documentation/beginners-guide-to-site-translation/

If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

The topic ‘[Closed] Language Switcher is not working’ is closed to new replies.