This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 1 year, 7 months ago.

Assigned support staff: Bobby.

Author Posts
February 26, 2018 at 12:07 pm #1529093

Edward Zilliacus

I made a support ticket regarding this issue earlier, but having been away for a couple of weeks the ticket is now unfortunately closed to new replies. Here is the issue I am having problems with:

So far, I have translated the homepage of my website using the translation editor to one additional language: Swedish (I plan on adding two more languages). I have also added the language switcher to the primary menu and footer of my website. However, nothing happens when I click the desired language flag.

it does not work on the menu and it does not work on the footer.

Why does this happen & how can you help me?

Link to a page where the issue can be seen: hidden link

In the previous ticket (which was closed because I was away and inactive), I requested Forum Moderator (Named Otto) if he could be given access to my site and see that everything is installed properly. Otto agreed and I was asked to first do a back-up of my site (which I have now done) before he could log in and see what the issue is. This is where we left off.

I would love to Grant Access using the button below but have no idea what to include in the FTP details field or the Duplicator Package field. If I could do all this over the phone that would be extremely beneficial if that is possible.

I would like to continue with fixing this issue and would hope to resolve this asap 🙂

Thank you in advance for your help.

Edward

February 26, 2018 at 6:54 pm #1529668

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

February 28, 2018 at 2:25 am #1531253

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

It should be resolved now 🙂

The values were just missing from the database, this is a known situation with GoDaddy servers.

February 28, 2018 at 9:11 am #1531489
Edward Zilliacus

Awesome Thank you that went fast!

However, there are now a couple of issues that have arisen.

1. When clicking to view the homepage in Swedish, a sidebar has appeared on the right-hand side, including a search bar, recent comments, archives etc. This messes up the layout of the page completely.

2. The menu does not work on mobile. It has become transparent.

Could you have a look at this?

Thank you in advance again,

Edward

New threads created by Bobby and linked to this one are listed below:

https://wpml.org/forums/topic/split-language-switcher-is-not-working/

February 28, 2018 at 10:23 pm #1532393

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

As this issue is resolved , the new ticket has been opened for the new issue.