This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Jamal 2 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
August 6, 2019 at 10:04 am #4346139

christianV-15

I am trying to: get the WPML tool running at the Landingpage

Link to a page where the issue can be seen: hidden link

I expected to see: That the language switcher works

Instead, I got: just the english site

August 6, 2019 at 10:30 am #4346403

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Can you please paste your WPML Debug information in the Debug information field? This would give me more information about your website.
- http://wpml.org/faq/provide-debug-information-faster-support/

Can you also check if the homepage is translated?

Otherwise, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal
WPML Support

August 6, 2019 at 11:22 am #4346763

christianV-15

Here is the debug code

August 6, 2019 at 12:06 pm #4347113

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback.
Can you confirm that the homepage is translated? Can you allow me temporary access to check this further?

Best regards,
Jamal

August 7, 2019 at 10:58 am #4354069

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

From what I gathered so far. The homepage is set to the page Home(when logged in as admin, the "Edit Frontpage (Advanced Layout Builder)" in the admin top bar points to the page Home).
But when checking WordPress reading settings in Settings->Reading. The homepage is not set to any page. See the attached image "home-page-not-selected.png".

I suggest setting the homepage and the blog page as shown in the attached image "correct-settings.png". I am not sure if you would like to use the Blog page or another page in the second dropdown.

I hope this helps. Let me know what you get.

Best regards,
Jamal

August 7, 2019 at 11:09 am #4354167

christianV-15

Hey Jamal, i changed the settings in the WordPress menu, but the problem is still there

August 7, 2019 at 11:24 am #4354261

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback, I can see that. Finally, I found a redirection by the plugin "Redirection" that is the cause of this issue. See the attached image. After disabling the redirection, the issue was solved. But you will need to check in an incognito window or another browser as the redirection might be cached by your browser. Please notice that browser redirect is enabled, so you might need to try twice if you go directly to hidden link. This should work from the language switcher.

Best regards,
Jamal

August 7, 2019 at 11:27 am #4354337

christianV-15

Thanks a lot, you made my day 🙂

August 7, 2019 at 11:34 am #4354385

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I am happy I could help. Please mark this ticket as resolved. And feel free to open a new ticket for any issue related to WPML.

Best regards,
Jamal