This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 9, 2019 at 11:49 am #3775743

aikateriniC-2

Hi,

1) I set my default language to Greek and secondary language to English. The problem is that when I click on my domain it is redirected to domain/el/

2) The default content was in English, and I have set the default language to Greek. The problem is that when I try to add pages to the Greek menu, the pages are not indexed. How to massive pass all the content to Greek and then translate it?

3) Language switchers show only my secondary language (English) and not my default.

Best

May 9, 2019 at 1:06 pm #3776283

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Let's take care of each question, one at a time. First of all, is there any rewrite rule on your website (added to the config files or maybe through a plugin) that might be making the homepage be redirected to /en/? You can check Dashboard → WPML → Languages → Language URL format area. Here, if you're using the Different languages in directories option, you can see a checkbox to Use directory for default language. If this is checked, the homepage should be redirected to the default language. Since this is not redirected to Greek (you said that this is the default language), can you give me access to the dashboard area so I can check things out a bit closer and see why is this happening, please?

Thanks,
Radu

May 13, 2019 at 4:10 am #3794981

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I just checked the default language and I no longer see that redirect to /el/. Have you managed to sort this out? Also, I can see the language switcher on Greek languages too (while initially you told me that the switcher is only showing on the secondary language).
Last but not least, do you still have issues adding elements to the menu? If yes, could you tell me exactly what steps are you taking in order to follow them too and see where the problem is, please?

Thanks,
Radu

May 15, 2019 at 11:42 am #3815825

aikateriniC-2

Hi,

possible is something wrong with the theme I use. The pages are redirected by language but the urls are wrong in some cases. Please, how to share this urls privately?

Best

May 16, 2019 at 11:22 am #3825477

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I set the next message to be private so you can safely send me all the links. Just give me any detail you can about this issue and I'll check it out.

Thanks,
Radu

May 23, 2019 at 12:39 am #3870023

aikateriniC-2

My issue is resolved now. Thank you!