This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 39 replies, has 3 voices.

Last updated by simonH-36 2 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 4, 2019 at 10:08 am #3533827

simonH-36

I am trying to: Link to translated page when switching language

Link to a page where the issue can be seen: hidden link

I expected to see: When I switch language to Chinese, it should show My Account page in Chinese (hidden link).

Instead, I got: It only links back to home page (hidden link) in Chinese

April 4, 2019 at 2:21 pm #3535775

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

It seems to be working for me when I switch languages using the language switcher both in the header or footer - it takes me to hidden link (see image). Have you managed to get this working in the meanwhile?

Everything looks properly translated.

Regards,
Bruno Kos

April 8, 2019 at 2:35 am #3553535

simonH-36

Hi,

This is just an example to describe the problem that I encountered.
BTW, you can try to visit any pages and switch languages in between. you can then replicate the problem that I encountered. Thanks

Isabel

April 8, 2019 at 10:11 am #3556435

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Instead, I got: It only links back to home page (hidden link) in Chinese

This reason for this is because these aren't actual links, but only anchors on the same page.
hidden link
hidden link

So this is in fact one page, that's why menu switcher takes you to home page as well.

Regards,
Bruno Kos

April 9, 2019 at 2:39 am #3562247

simonH-36

i dont think that it was caused by the link I set, please refer to hidden link

BTW, you should try to visit, about us, pricing, my account page, etc..... and try to switch languages in between, you can then replicate the issue that I reported. Sometimes, it wont direct to the corresponding Chinese page. 🙁

Isabel

April 9, 2019 at 8:36 am #3564327

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I can see it now - can you tell me these are custom created switchers, or WPML default? It seems to me that when I am on any English page, all the language switchers simply point to hidden link

Can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Seventeen as it will tell us if there is an interaction issue with your theme

Please make a full backup of your site before trying this or make these changes on a staging/development site!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

April 10, 2019 at 4:27 am #3572353

simonH-36

Hi,

It is hard to apply the changes you mentioned for testing as it is a live site.
However, I believe that it related to cache issue as
1. I tried to replicate the site to my local machine and it works fine.
2. I tried to clear cache and recreate ST DB cache table through WP > WPML > Support > Troubleshotting. It works initially but it doesn't after a number of clicks.

I would like to know how to get this fixed? Can you please advise a solid solution for it? Thanks

isabel

April 10, 2019 at 7:33 am #3573125

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

1. I tried to replicate the site to my local machine and it works fine.

On your local machine, does this also happen:

It works initially but it doesn't after a number of clicks.

Or is this is happening on the live site only? If yes, what kind of caching are you using on the site, have you tried disabling these, do you have a server-side caching also?

Regards,
Bruno Kos

April 10, 2019 at 7:36 am #3573159

simonH-36

It wont happen on my local machine. I dont know what kind of caching we are using on the site as our site is hosted in wordpress.com. However, I dont think I can disable it. Can you please advise?

Isabel

April 10, 2019 at 8:06 am #3573291

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Isabel,

So just to confirm, you are using any of hosting plans from here?
hidden link

Can I ask you the following then? In order to debug this issue , I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

If yes, I will need WordPress admin username and password so I could do this. I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

Regards,
Bruno Kos

April 10, 2019 at 8:53 am #3573741

simonH-36

Hi,

yes, we are using one of the hosting plan from hidden link
BTW, I have other open tickets regarding WPML. They have requested to install duplicator plugin into our site but not fail. However, I have a copy of my site which duplicated by all in one migration plugin (https://wordpress.org/plugins/all-in-one-wp-migration/). I thought that it is good and enough for you to create one on your localhost and try it (I used this to duplicate the site to my local host too)
Let me know if you are ok for this. If you are ok with this, please create a private channel for me to share the url of the copy to you, Thanks

Isabel

April 10, 2019 at 9:56 am #3574577

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I thought that it is good and enough for you to create one on your localhost and try it (I used this to duplicate the site to my local host too)

I don't see why not - I've set your next reply as private, so that you can put links inside. Please provide wp-admin info and you can put that link into Duplicator package field.

Regards,
Bruno Kos

April 10, 2019 at 9:58 am #3574581

simonH-36

Hi,

In order to share the copy to you, can you please provide your email address so that I can share the link to you? Thanks

Isabel

April 10, 2019 at 10:14 am #3574781

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you upload that file into service like DropBox and Google Drive, create a shareable link (public, so no need for emails), I will download the package and will let you know once I am done so that you can free up the space there?

Regards,
Bruno Kos

April 10, 2019 at 10:16 am #3574787

simonH-36

the copy is now in google drive. However, share the copy url in public is insecure, can you please give me your email address so that I can share it to you in a private way?

Isabel