This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Radu 3 weeks, 3 days ago.

Assigned support staff: Radu.

Author Posts
September 21, 2019 at 9:59 am #4615741

marcusC-6

I am trying to: Change the language of our routes pages and in url the language code is not changing and stayes the current page language code. and after changing the lanuage the language switcher is disappear.

Link to a page where the issue can be seen:

I expected to see: hidden link

Instead, I got:hidden link

September 23, 2019 at 4:26 am #4620159

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marcus,

Thank you for reaching out the WPML support!

I had a quick look at the page and I could see that there's an issue when trying to change the language. Is there any chance that you could give me access to the dashboard area, please? This way I'll be able to have a closer look at this and see what might be causing the issue.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

September 23, 2019 at 7:57 pm #4626415

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marcus,

Can you check again this page hidden link and tell me if you still have issues changing the language, please? I just tried to do this right now and it works pretty well.

Thanks,
Radu

September 24, 2019 at 6:09 am #4628167

marcusC-6

Hi Radu. I am still not able to get the language switcher to work. It seems to be ok when moving from English to French but all other languages seem to break the layout. For example - hidden link. Screenshot of this page attached. Thanks, Marcus

September 24, 2019 at 7:49 am #4628679

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marcus,

I just had a look at the Italian page you attached and I could see that the layout issue is related to the length of the menu items. For example, if I remove a couple items, things are starting to look fine again (see the attached screenshot). When there are too many items, the menu is made to go under the logo (and make things look bad).

In this case, can you try to edit the menu (through Dashboard → Appearance → Menus area) and leave only a couple items to the 1st level of menu. This will make things go back to normal.

Thanks,
Radu

September 24, 2019 at 12:54 pm #4631723

marcusC-6

I'm really having problems with this. I could see the menus were not configured properly so that has been corrected. Now the language switcher resets to a default version in the wrong order or the correct version with the flags appears to randomly appear or disappear. How do I switch off this default version and get it to display the switch with the flags and all languages in the correct order? - hidden link

September 25, 2019 at 6:35 am #4635961

marcusC-6

Hi. Just following this up as I am unable to update the live site until it is resolved. See images attached in case the problem is not clear. This problem seems to keep recurring. Thanks

September 27, 2019 at 8:00 am #4652183

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marcus,

I checked the menu a bit closer and I could see that no language switcher is set through Dashboard → WPML → Languages area. You set the order of the items but the language switcher is not set to be shown on a menu, widget, or footer. Can you tell me how did you add the language switcher at the end of the menu, please?

I checked the child theme and I could see that you're using some code in order to create the menu. Also, can you try to add the language switcher to footer (using the option from WPML → Languages area, and tell me if the order is the right one?

Thanks,
Radu

The topic ‘[Closed] language switcher is not working properly for routes of the pages.’ is closed to new replies.