This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.23 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by taimurM 1 month, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
September 10, 2019 at 11:35 am #4544745

taimurM

Hi This is Waqas as My website was in English later I translated in the Arabic now I set my Default language to arabic But Option Language switcher menu is not available !

Jovento.com on second screen shot i am unablr to find my original menu

September 10, 2019 at 12:31 pm #4545309

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

1.
The language switcher will appear only if the translation of that page is completed 100 percentage? did you fully translate the page and completed 100% ?
You have to have green 100% here: hidden link when you do that.

2.
Please go to WPML -> Languages->enable "Link to home of language for missing translations" and "All posts (display translation if it exists or posts in default language otherwise)."
Do you see the language switcher after that>

3.
Add a footer language switcher, what are your results ?

4.
Please go to WPML => Support , and click on "Troubleshooting" while in the Troubleshooting page please perform the actions. (specifically "set language information" but i recommend performing all of them"

Let me know how it goes.

Regards,
Riffaz.

September 10, 2019 at 8:15 pm #4548787

taimurM

My issue is resolved now. Thank you!