This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by lauraN-2 1 week ago.

Assigned support staff: Bobby.

Author Posts
October 2, 2019 at 4:00 pm

lauraN-2

I am trying to:
Switch between languages using the language switcher at the end of the menu

Link to a page where the issue can be seen:
hidden link

I expected to see:
A normal size flag to click and switch to English (which at this time is just a copy of the Dutch page)

Instead, I got:
When you open the page you don't see a flag at all, when you scroll down the flag does suddenly show up but it's very small. We don't know why it isn't working. Could you please look into this?

October 2, 2019 at 5:49 pm #4682491

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

Are you still experiencing this issue?

When I visit your site I am able to see the language switcher as expected at the moment.

Please review my screenshots.

October 3, 2019 at 8:11 am #4685581

lauraN-2

Yes, I'm still experiencing the issue and I'm not the only one...

October 3, 2019 at 4:13 pm #4689769

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please review my screenshots, when I visit your site I see the flag in both languages at the end of the menu.

Please provide me with some additional information as at the moment I am not able to see an issue with the language switcher on your site's front end.

Additionally please do keep in mind that the menu's styling is not ruled by WPML but rather your theme's CSS. Also, our flags have a dimension of 18px by 12px by default.

If you wish to have a flag that is greater than 18px by 12px, this can be achieved by uploading your own flag in the WPML admin area.

This way you can use a bigger flag and it will display just the way you want it.

To upload your own flag go to WPML > Languages > "Edit Languages" where you will be able to upload your own flag images -> Upload Flag.

October 7, 2019 at 8:24 am #4705365

lauraN-2

I've added two screenshots so you can see my issue. As you can see when I open the page the flag isn't there at all. When I scroll down it does appear but really tiny.

October 7, 2019 at 7:30 pm #4710461

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the screenshots!

I was originally not able to reproduce this issue when I visit your site without scrolling I get the correct Language switcher as expected, therefore I had some of my colleagues tests and got some people that could see it without scrolling and some that got the same results as you.

This is happening due to your theme's responsive code, which resizes your page to fit in smaller windows.

The difference of screen resolution is triggering the script to show/hide the language switcher along with the menu to become bigger or smaller, which is why you are seeing the switcher in small size.

To test it please try the following:

1. Minimize your browser window
2. Resize it as big as possible and then start dragging into a smaller window to see the change.

Here is a screencast of me showcasing the above:
hidden link

October 7, 2019 at 7:42 pm #4710481

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please do note that we currently do not provide custom work within the forum but the following simple CSS rule should be able to resolve the issue with the menu resizing.

Please add it to your theme's Additional CSS area and let me know your results.

.menu-item.wpml-ls-item {
    min-width: 50px !important;
}
October 9, 2019 at 1:24 pm #4723313

lauraN-2

My issue is resolved now. Thank you!